Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum > Extremely High Oil Pressure?

Join Wrangler Forum Today


Thread: Extremely High Oil Pressure? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-05-2006 06:13 PM
BigMike mmasuperman12--I also have this problem...But for me..My oil pressure is only high while my engine is cold...I replaced the thermostat and got a new cap for my radiator and all is fine i must say.

To everyone else--Thanks for helpin me out guys
02-26-2006 07:51 PM
mmasuperman12
opposite end of the spectrum

last night we got about a foot of snow and me and a few buds decided to go do some donuts down at the local highschool parking lot. all gauges were normal at the start but near the end of all of it i looked down whil idleing and my oil pressure was about 20-25 but as soon as i step on the gas it goes back up, checked the oil and it looked fine and looked to see if i could see any coming out of anywhere and on the ground couldnt find anything. any ideas? ill say it was worth it and seein the local police was too.
02-15-2006 09:05 PM
daddyjeep The only thing I can of that would make the fluid spew out of the overflow is if the rest of the system is sealed up really well. Whn the pressure builds up due to the overheating it has to escape somewhere. Actually, That is the purpose of the cap, to release excessive pressure. You most likely need a cap. It must be frozen up. Like said above, get a thermostat and a new cap and see how things go.
02-14-2006 10:33 AM
BigMike Any idea why it spit out fluid? Im not sure if a faulty themostat would do that...but then again, im not too sure...Im having trouble finding out where it spit out all the fluid from also...I think its somewhere in the general area of the back of the engine compartment...near the master cylinder
02-14-2006 05:41 AM
3jeepguy very common they do that just before the rupture
02-13-2006 07:11 PM
amerijeep
Quote:
Originally Posted by 1BLKJP
My vote is on this too. Doesn't sound like the tstat is opening correctly all of the time.

Right. I also had a situation once on my old 4X4 Dakota where the inside of the radiator hose was collapsing on the inside when it got hot. You couldn't see it from the outside. I've been told this is fairly common but I have only had it happen to me once. Not really sure how common it is.
02-13-2006 06:28 PM
1BLKJP
Quote:
Originally Posted by amerijeep
I think you need to replace your thermostat and change all of your raidator hoses. Probably wouldn't hurt to get your radiator pressure tested at the same time.
My vote is on this too. Doesn't sound like the tstat is opening correctly all of the time.
02-13-2006 08:12 AM
BigMike
Quote:
Originally Posted by amerijeep
Where do you get your gas? It takes longer than six minutes for me to pump gas and pay for it. You must never have to wait behind anyone.
BJ's has the cheapest gas around. Because of the snowstorm the line was absolutely huge. A six minute wait was not bad at all....People were waiting for 10+ min.
02-12-2006 09:29 PM
amerijeep
Quote:
Originally Posted by matt22
Why were you waitning for gas for 6minutes?
thats seems like a really long time.
Where do you get your gas? It takes longer than six minutes for me to pump gas and pay for it. You must never have to wait behind anyone.
02-12-2006 09:27 PM
amerijeep I think you need to replace your thermostat and change all of your raidator hoses. Probably wouldn't hurt to get your radiator pressure tested at the same time.
02-12-2006 09:01 PM
matt22
Quote:
Originally Posted by BigMike
Well the unthinkable happened and im not sure if it was because of the oil pressure but while i was waiting inline for gas (6 min.) at idle my car suddenly over heated. Smoke is coming out from under the hood and when i moved my car i saw there was a huge puddle of what i believe was coolant. Is it possible that under the heat, the pressure built up so much it spit out some coolant? It didnt come from the radiator tho...There are a bunch of wet marks by the engine coolant resivore and thats where it was mostly steaming from......? I have no idea what happened....Do you? (by the way, i still didnt buy a new sender unit for the oil pressure, so yea it is still running high but then after 15 min. of driving it comes close to normal but not just quite yet)

Why were you waitning for gas for 6minutes?
thats seems like a really long time.
02-12-2006 07:45 PM
BigMike Well the unthinkable happened and im not sure if it was because of the oil pressure but while i was waiting inline for gas (6 min.) at idle my car suddenly over heated. Smoke is coming out from under the hood and when i moved my car i saw there was a huge puddle of what i believe was coolant. Is it possible that under the heat, the pressure built up so much it spit out some coolant? It didnt come from the radiator tho...There are a bunch of wet marks by the engine coolant resivore and thats where it was mostly steaming from......? I have no idea what happened....Do you? (by the way, i still didnt buy a new sender unit for the oil pressure, so yea it is still running high but then after 15 min. of driving it comes close to normal but not just quite yet)
02-11-2006 09:22 PM
jp4ever we get great oil pressure every time we turn the key to on yep its a jeep thing
02-07-2006 05:56 PM
R.P.M.
Oil pressure

when you pickup your sending unit about $30 something if I remember right, they sell a special socket to install. At least
its easy to get to. Our had ruptured months before we bought
the jeep so we had quarts of oil down the block and all over thepad and tranny.
02-07-2006 10:28 AM
BigMike Okay, thanks guys...Ill let you know how things turn out once i buy a new sending unit
02-07-2006 07:44 AM
naviathan I've seen this a lot on the Jeeps and it's always been the sending unit. I'd be surprised if it wasn't.
02-06-2006 08:42 PM
Fapple Hopefully it is the oil sending unit. I'm basically new to the Jeep world, but not to the automotive world. I have seen several engines running very high oil pressure due to plugged oil passages. Most of the time flushing the engine resolved the issue but not always. Getting back to what I said before... hopefully it is the oil sending unit.


Frank
02-06-2006 02:11 PM
BigMike Seems easy enough...Thanks for the input
02-06-2006 01:54 PM
naviathan Change your pressure sensor. When they get old they read high pressure all the time.
02-06-2006 01:21 PM
BigMike
Extremely High Oil Pressure?

Im not sure if any of you wrangler guys had the same problem. I have a 95' Wrangler and my oil pressure is extremely high...to the point whre im almost maxing out the oil pressure gage. Is this normal for jeeps to do? I tried changin my oil thinking it would go down but it hasnt. I just want your guys opinions on what to do and if this usually happens to jeeps Thanks

--Mike

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:46 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC