Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > PCV Valve situation

Join Wrangler Forum Today


Thread: PCV Valve situation Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-19-2010 05:50 AM
reondadomino I went ahead and bought a new one and a new hose. The new one is considerable smaller and seems to fit in the grommet perfectly. The only trouble now is getting it to stay in the grommet. Dunno if it's tension from the hose or what, but the PCV valve gradually works its way out of the grommet... Think I'll take your advice and see about replacing the grommet today too.
10-18-2010 10:49 AM
aelwero clean the PCV really well and stick a new grommet in. The rubber gets old and once the oil can seep in just a little, it goes downhill from there with a quickness. Replacing the hose will help considerably too.

You won't leak a whole lot of oil out of an old loose one, but it will leak some.
10-18-2010 10:19 AM
reondadomino
PCV Valve situation

The PCV valve on top of my valve cover is really loose. It sits in the grommet but not securely. Haven't bought my manual yet so I was wondering if someone could tell me if this is normal? Or do I need to replace it?

And could this cause oil leakage? There doesn't seem to be oil coming from around the PCV valve but you never know.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:17 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC