Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Got my Bilstein 5100 Shocks in today!!

Join Wrangler Forum Today


Thread: Got my Bilstein 5100 Shocks in today!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-23-2007 02:09 AM
jherrin215 Thanks, yeah I knew it should be a simple project, hopefully it will be!!
05-23-2007 01:25 AM
AzTJ shocks are nothing to install... just be sure the e-brake is on and the wheels have blocks behind them so it wont move at all. Blast everything with PB-Blaster a good few hours before hand and it should be easy as pie.
05-23-2007 01:17 AM
jherrin215 Thanks Bigjeep very helpful post!! I hope that it is a simple process like it very well should be. I just hope I dont have any bolts break on me like some have had. And Scout, I will be sure to give my opinion when I get them installed!!
05-22-2007 10:08 PM
Scout Cool! I can't answer your question but I'll be interested in knowing how well you like them.
05-22-2007 09:32 PM
mrbigjeep my only suggestion is unbolt the old shocks and then install the new shocks.

thats all i can give as i didn't have any problems with mine
05-22-2007 01:47 PM
jherrin215
Got my Bilstein 5100 Shocks in today!!

Anyone have any suggestions, tips, or little tricks for me to use when installing these?? I have heard the stories of breaking off the mounting bolts, and hope that i don't have to mess with this ordeal!! Any suggestions would be very appreciated. thanks!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:17 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC