Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Idle Problems

Join Wrangler Forum Today


Thread: Idle Problems Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-07-2013 12:50 PM
Fourthwolf I had a similar problem with my 2000 TJ 4.0L bogging down when idling. It would stall out if I didn't throw it into drive after starting the engine. Removed the throttle body and IAC and cleaned them off and now it idles fine.
05-24-2007 08:42 AM
MCG I seems like it was a dirty body throtle, I just drop some carb cleaner and after that It works just normal,the Jeep didn't throw any code.
Now its working .
Thanks again.
05-23-2007 10:16 AM
Jerry Bransford Just in case, the IAC is located on the passenger-side of the throttle body.
05-23-2007 10:11 AM
MCG Ok guys thanks a lot ,Later on I will go to my friend's shop and I will print out your posts and I will try to find the problem. I will post later what was the problem.

Thanks.
05-23-2007 09:26 AM
JCS05Rubi It may just be the heat shield vibrating, not the honeycome inside. Make sure the cat is actually bad before you replace it. A bad cat will effect driving at speeds also. Usually feels like your towing a battleship anchor.

Thanks Jerry, I couldnt remember if the whole throttle body had to come out or not. I figured he could clean it all up while he was at it
05-23-2007 09:17 AM
MCG
Quote:
Originally Posted by JCS05Rubi View Post
Take a rubber mallet or your hand (when cold) and hit the cat, or exhaust pipe real close, and see if it rattles
Yes It does,I forgot to mention that.I heard that cat. rattles when I shut off the engine or in normal idle,like any broken cat.
I hope may be is just that the problem.

Thanks.
05-23-2007 09:15 AM
Jerry Bransford I'd first guess a dirty IAC (idle air controller). The IAC is what meters air into the throttle body at idle since the butterfly valve that lets air into the engine at other times is closed at idle. Take it off (it's only held on by two small T-25 bolts) and gently clean its solenoid-actuated plunger with carb or throttle body cleaner and a rag or brush. Clean the throttle body oriface it meters air through too.
05-23-2007 09:00 AM
JCS05Rubi If you have a TJ, you are fuel injected and should never need to give it gas to start on a normal operating engine.

With that said, there are numerous things to mess with your idle; fuel injectors, ECU, sensors, vacume lines, intake/exhaust obstructions, idle air control etc etc.

I would start with the idle control and Catalytic convertot first just to rule them out. Most likley its the idle control.

Take a rubber mallet or your hand (when cold) and hit the cat, or exhaust pipe real close, and see if it rattles (shouldnt)

Remove your intake tube, make sure nothings in there. Pull your throttle body and clean it out, paying particular attention to the idle control shaft thing.

Take your jeep to someone with a scan tool and see if anything obvious shows up on real time data stream

my .02
05-23-2007 08:47 AM
MCG
Idle Problems

Mine its a 00' 4.0L ,5 spd.
When I first started in the morning took longer than usual to start,actually I had to push the gas harder to make it run,When it was cold couldn't stay on Idle it stalled righ away unles I leave th rpms @ 1000,but after warming up,well I drove it to my job like 20 min from where I live,and I try to keep in idle and it stays but around 150 or 200 rpms,way to low,any sugestion? fuel pump,ECU,any idle control censor??
other wise the Jeep runs good ,the only problem is whe i leave the gas and the car stalls or stays in very low rpms.

Any sugestion,or similar experience?
Thanks a lot guys.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:59 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC