Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > RPM Regulator?

Join Wrangler Forum Today


Thread: RPM Regulator? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-26-2007 07:39 PM
Triple88a well do the converter and hope for the best man we wish ya luck while you're at it get a high flow
05-26-2007 04:32 PM
jkincel I have checked everything and narrowed it down to a catalytic converter issue... due to all the misfires I was getting while replacing the distributor and timing. It was my first time swapping out these parts and adjusting the timing, so I had started it quite a few times in the process of trial and error. Now I have an expensive mess on my hands... but the experience is invaluble!
05-26-2007 03:02 PM
Triple88a to me it also sounds like sparky problem.. thinking out loud.. when idling or low rpm the spark fires just before Top dead center (TDC).

when at a higher rpm the spark needs to fire even earlier to get the fuel burning for TDC. Does it sound like its knocking when above 1k rpm? I'm thinking of it being too advance where the air/fuel mixture flames up way too early and knocking.. you say you checked everything perfectly.. i'm wondering cant you swap the old stuff back in and try that way and see if it works?

do you think you can have some one look at the tail pipe to see if any smoke is going out when it stops accelerating..revs.. color...
05-26-2007 12:02 PM
jkincel quick update I have timed everything exactly the way it should and double and triple checked everything, reset the distributor, brand new cap and rotor, new plugs and wires. this last time it accelerated fine but a little past 2000 RPM it made a poping noise and became slugish, and now wont accelerate past 1000RPM's again. I have been at this for 3 days with the resolve of one problem leading to the next... please any advice is appreciated
05-26-2007 10:11 AM
jkincel the distributor was aligned and bolted immediately, also the bolt for the distributor tightens between a fork so there is no way for the distributor to rotate.
05-26-2007 10:02 AM
jkincel it is an old distributor from a 92 cherokee 4.0, I have followed all istruction for timing... line up the notch on the vibration dampener to the 0 mark, align rotor to number one position, is there anything I am missing?
05-26-2007 09:22 AM
4.0l sahara If you rotated the distributer at all from the first location you would of retarted or advanced the timing.
05-26-2007 09:20 AM
4.0l sahara Timing
05-26-2007 09:19 AM
4.0l sahara never heard of it. Rpm limiter? But that wouldn't cause your loss of power.The 4.0 rev limiter is 5,000rpm
05-26-2007 09:19 AM
Scotty355 RPM regulator? I always thought that would be your right foot.
It almost sounds like a timing problem.
Is it a new distributor or an old one you put in there?
05-26-2007 09:15 AM
jkincel
RPM Regulator?

I have recently swapped out my distributor, timed, and replaced distributor cap and rotor. 98 4.0 6cyl turns over right away, and idles perfect. The problem is when I start driving I loose any acceleration past 1000 RPM's, tried shifting into 2nd gear and same thing... a local mechanic said something about an RPM regulator but, I have no Idea where to find it, how to adjust, or if that is even the problem any thoughts? Thanks for taking time to help me out.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:03 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC