Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > New jeep owner with electrical problems

Join Wrangler Forum Today


Thread: New jeep owner with electrical problems Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-08-2010 08:19 AM
DaveWhittaker Thanx will keep looking and will update progress
11-07-2010 07:07 PM
wasomma
Quote:
Originally Posted by DaveWhittaker View Post
the o2 sensor is fairly new the thing wont fire at all now
balls, theres a bunch of users on here who have carb'd jeeps, I'm sure they'll help you out. There are a bunch of posts in this forum about jeeps with carb engine problems and how they solved them. I would do a little scouring if no one gets back to you.
11-07-2010 02:01 PM
DaveWhittaker the o2 sensor is fairly new the thing wont fire at all now
11-07-2010 02:00 PM
DaveWhittaker the choke is ok thanx for trying
11-06-2010 05:12 PM
wranglerdad is your choke stuck?
11-06-2010 02:51 PM
birtydugger Could be the 02 sensor? (lambda)..funny how it starts up fine...then when warm cuts out again!!?..
11-06-2010 01:19 PM
DaveWhittaker
New jeep owner with electrical problems

I just got a 1990 YJ after 1 week it has electrical issues. I have new coil,cap,rotor. It turns over great but only runs for 5 mins. Battery and grounds are good. Want to know about ignition module or pick up coil. Can they be tested at home? If so how? can anybody help a newbee jeep guy?
I really want to play in the mud this time of year.
Forgot to say 4.2L carbed with new steering coloum so dont think ignition switch.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:35 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC