Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 95 YJ middle instrument cluster electrical issues

Join Wrangler Forum Today


Thread: 95 YJ middle instrument cluster electrical issues Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-12-2010 08:14 AM
60mg It ended up being a crappy connection on the contacts of the plug. Just fixed it by cleaning and greasing the pins with waterproof lube.
11-09-2010 09:52 PM
Garyk Sounds like a shorted wire somewhere
11-09-2010 06:50 PM
60mg
95 YJ middle instrument cluster electrical issues

I started having this issue when my middle instrument cluster would act fine until I'd turn my headlights on. then some will go down as if they were powered down while temperature gauge would show me that the engine is overheated. As soon as I turn the lights off everything goes back to normal. Is this some sort of a known issue? In any case, I was hoping someone possibly had it in past and has a resolution for it.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:19 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC