Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum > A/C Problems with 2014 JKUR

Join Wrangler Forum Today


Thread: A/C Problems with 2014 JKUR Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-04-2014 06:20 PM
Rockntroll I was afraid if that. My first trip to the Chrysler service dept, yeah
03-04-2014 06:11 PM
Old Dogger Yep, all of these electronic modules are scary, just more to go wrong..........
03-04-2014 06:03 PM
bbtj Take it to the dealer, that is why you have a warranty.
03-04-2014 05:43 PM
Rockntroll I just noticed the ATC on my new Sahara with 400 miles totally inop and will not heat. It seemed to work fine last weekend on AC when it was 80 degrees out. Manual heat works fine. Any quick fixes, or does this mean a trip to the dealer?
02-05-2014 11:45 PM
87_WhyJay
A/C Problems with 2014 JKUR

This started when I was sitting in my brand new 2014 Rubi unlimited at work as a security guard at a construction site. It started with 12 miles on the odometer. I noticed that the electric motors that activated the 4 doors under the dash, would continuously activate throughout my 8 hour shift. Sometimes 20 times an hour. Engine off, key in off position, A/C in off position, nothing on means NOTHING ON. Right. The doors would cycle in 4 different and distinct sounds, then repeat many times throughout the night. When I told the dealer about this, they checked another NEW 2014 JKUR on the sales floor, and it also does the 4 doors cycling thing ALL THE TIME so it's not unique to mine.

Knowing that all parts are made of plastic these days, this means premature failure of all the vent doors and everything connected to them that was moving unnecessarily.

The only thing I could think to do was disconnect the negative battery cable and reset the computer and try it again. This did not fix the problem, it only made my AUTO TEMP mode go spastic. I can be using the A/C in the auto mode and all of a sudden, it changes to FULL HOT mode or FULL COLD mode without me touching the controls. I actually have to turn the system off in order to not be froze out or cooked. A couple of engine cycles later of turning the key off and back on, then it starts working normal.

I have been to the dealer on both problems and they are scratching their heads. "FANCY THAT" They have no clue what the problem is. They have a call into CHRYSLER in Detroit for them to work on it.

Does anyone else have this problem with the 4 vent doors cycling open and closed even when everything is off? It takes sitting in your heep for about 30 minutes with everything off in order to discover this. If you don't hear them cycle in 10 to 15 minutes, I'd guess yours isn't doing the same thing mine is.

ALSO, has anybody had their A/C units NOT work properly after removing the negative cable from the battery? The dealer told me to remove the dash cover they sold me the same day I bought the Jeep to see if that fixes the problem. I told them the problem started when I removed the battery cable, not when I installed the dash cover when my jeep was 1 day old. Just to keep peace with them, I removed it and am testing it with a bare dash now. Thanks for any help that can be added.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:01 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC