Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Front Track Bar Issue

Join Wrangler Forum Today


Thread: Front Track Bar Issue Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-17-2010 04:30 PM
jwm1986 I am still trying to figure out a way to correct it. I normally will just tack on a washer on the outside, but you can't get to the back side of that bracket which is where the problem is on mine! I am probably going to end up cutting the bracket off completely and making a new one out of something thicker.
11-17-2010 04:28 PM
NUTnOUT where it connects by the axle.
11-17-2010 03:49 PM
jwm1986 Are you talking about the bolt at the axle end or the frame end? The axle end is a very common problem and mine is as you describe currently. I just found a tighter fitting bolt and tightened it up more, so far so good. But I know before long I am going to need to fix it right.
11-17-2010 02:41 PM
UnlimitedLJ04 stock track bar? If so, sounds like the bar is worn out. Easy fix, go to NAPA and pick up a new track bar. if not stock, post picture.
11-17-2010 02:38 PM
NUTnOUT
Front Track Bar Issue

so i've noticed that if i crawl under the jeep and someone turns the steering wheel back and forth, the lower bolt on the upper track bar (the bent one) moves back and forth in the mounting bracket like the hole is wollered out. anyone else have this issue before?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:51 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC