Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Clutch pedal issue - weird..

Join Wrangler Forum Today


Thread: Clutch pedal issue - weird.. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-15-2013 09:46 AM
Curtis97Tj I need to replace my clutch master cyl. I hope that fixes my hard shifting issue. Already did new slave cyl but no change
11-27-2010 05:13 PM
Got_Mud? It was the master cylinder. Figured I'd start with the cheapest part. Under $50. Took 30 minutes. I took the old one apart and it had a bad score in the cylinder. Weird... but it lasted 210k miles....
11-18-2010 10:21 PM
Got_Mud? So are we thinking that it's the master, slave, clutch, toss-out bearing, pressure plate or the Jeep got gas and developed an air bubble? I'm lost...
11-18-2010 07:29 PM
sppfields Try bleeding the clutch. If that doesnt help, then its probably the clutch slave cylinder. definately not fun.
11-18-2010 04:22 PM
Got_Mud? No other ideas?
11-18-2010 07:45 AM
Got_Mud? Well that doesn't sound like a lot of fun...

Would it make sense to replace the whole thing since I've got it apart?
11-18-2010 07:33 AM
Fweaky The throw out bearing or clutch release bearing may be going bad.
11-18-2010 07:01 AM
Got_Mud?
Clutch pedal issue - weird..

Hi all,
First off, 1995 YJ, 4.0L 5 speed

All was well with my Jeep on Tuesday. I drive quite a bit and know when something is different.

Wednesday I drove about 8 miles and shut it off. When I started it back up, the clutch pedal was acting like it was "stuck" and would not depress. I held hard pressure on it for about 2 seconds and it slowly moved about an inch, then depressed normally. If I took my foot completely off the pedal, it sticks and I have to give it pressure until it releases, again about 2 seconds.

It feels like a power brake pedal, with the engine off, after pumping it a few times - that hard; right up until it releases.

If I "rest" my foot on the pedal - not press it, but just rest it, it depresses normally. The pedal has about two inches of "play" before it starts to disengage the clutch.

The tranny shifts fine, no issues and no problems, once the pedal is down.

The master cylinder is full of fluid, and no leaks that I can see.

I crawled under the dash and could not see any binding or anything in the pedal itself.

Before I go and replace everything on a guess, I thought I'd toss this out for the more knowledgable folks and see what you all thought.


Thanks for any input or advice!

::edit to add - there have been no changes, upgrades, downgrades, wheeling, or anything at all abnormal lately. This just "happened

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:05 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC