Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics > can someone tell me how this is wrong? (CB ant. mount)

Join Wrangler Forum Today


Thread: can someone tell me how this is wrong? (CB ant. mount) Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-18-2010 11:15 PM
hookuspookus too tired ! if you need more info write back
11-18-2010 11:09 PM
hookuspookus your c/b tech is as smart as a box of hammers your supposed to have the body as a ground ,thats why they are called ground plane antennas . but ...... thats not really a good place to mount it because when you key up the ant. is close to the body and will only really transmitt in back of you ,sooooo what you should do is mount a wilson 1000 on your roof not a magnet mount but a roof mount and use the roll bar as your ground plane . i have 0 swr's and talk to belgium ,austrailia , north pole, falkland islands on my RCI-2950 and my radio shack trc-465 . i live in new jersey and just talked to denver yesterday with no linier amp from my jeep , works great ! 529 new jersey
11-08-2007 07:04 PM
MR.CLIFFORD Sure can. Should be like this.

11-08-2007 05:48 PM
drummerwookie
can someone tell me how this is wrong? (CB ant. mount)

i went to a CB shop today to get a new mic and to have them match my radio since i had never had it done, and they some how got to looking at my antenna mount on the back of my jeep. the guy comes in, in kind of a pissy way goes "the way you have your antenna mounted is all wrong" i asked what was wrong with it, and he gets even pissier about it and said that im using my entire jeep as a ground by doing it the way i am. i then told him its always worked before, and i had it mounted that way to my rubicon for 2 years and never once had a problem. he then just kinda huffs and puffs and threw his hands up and was like "well, im sorry, its just wrong" then after he cooled down from who the hell knows why that pissed him off, he explained to me that i need to put the mount upside down some how and that could work. but he said if i dont do something about it, it will fry my radio.

can any one explain to me how this is wrong and if so, how should i fix it?



Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:14 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC