Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Engine problems... please help

Join Wrangler Forum Today


Thread: Engine problems... please help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-09-2010 10:26 PM
mholloway1809 If you didnt overrev the engine or run it low on oil i think its possible the previous owner might have.
A 2002 jeep engine with only 40k on it, must have came from a wrecked jeep with serious damage.
Second, never buy a mechanic's personal vehicle. its the one that never gets fixed right.
12-05-2010 01:29 PM
robbyr on the first engine while i was in the air for that split second i was barely even giving it gas, but not sure how much exactly

on the second engine i was driving normally couldn't have been over 3000 rpm
12-05-2010 01:18 PM
mholloway1809 How many RPM's did you turn ?
12-05-2010 12:52 PM
robbyr
Engine problems... please help

i bought a 1993 jeep wrangler yj from a mechanic i've been using for a while
the truck is pretty hooked up with tires, lift kits, armor, and a beast brush guard. the truck has 120,000 miles on it. Straight 6

about 2 months after i purchased the truck i was in 4 wheel low doing some very low key offroading. i hit a bad bump got a bit of air and when i came down the engine was making a rattling noise. once checked out it turns out i blew a piston rod and needed a new engine. it was worth it to get one because of all the money put into the truck. i got the new engine (not brand new, it came out of a 2002 wrangler with 40,000 miles great condition) and no more than two weeks later while driving in 4 wheel high in the rain the same exact thing happened. same piston in the new engine. could i be doing something wrong or is it possible the truck is a lemon? the engine was insured but i still need to pay to have it installed. is it worth it?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:49 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC