Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Loosing power to radio, cig lighter, and turn

Join Wrangler Forum Today


Thread: Loosing power to radio, cig lighter, and turn Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-11-2012 05:11 PM
wickedyj95 true cold shrinks things and heat makes them expand this could becausing your connection loss. do as these guys said and start small with the fuse block and its conections i would pull each fuse one at a time and clean the contacts with steel wool or an abrasive equal. reinstall wait for cold .lol
12-28-2010 03:42 PM
Garyk Sounds like a bad connection(s) or corrosion at the fuse box..
12-28-2010 01:12 PM
ksplayland Thanks so much. I will do just that and see where i get! Happy Day!
12-28-2010 10:19 AM
chensley sounds like its shorting out when a load is put on your electrical system. I'd start checking fuses, grounds, and other junk also..make sure you have the CORRECT fuses in their proper spots. I know it's not a very systematic answer, and someone else will eventually chime in and give you a more direct answer.
Keep an eye out for any traces of water near the fuse box in the drivers side, and also the PCM on the passenger side engine bay.
Good luck, and welcome .
12-28-2010 01:15 AM
ksplayland
Loosing power to radio, cig lighter, and turn

Hello- So I have a 1994 YJ and as it turned colder my radio will not work when I first start the Jeep, after a minute or two it comes on. Now if I use a turn signal it looses power, or use power outlet, or adjust my blade it temporarily looses power to radio and power outlet. Sometimes it is a short delay and sometime it takes several minutes to get power back. Any ideas?
Thanks for you help!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:33 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC