Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion > Got caught in a downpour..now I have problems...

Join Wrangler Forum Today


Thread: Got caught in a downpour..now I have problems... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-24-2007 05:53 PM
penguin_in_a_cj not sure where on a jeep you would locate the cruise control servo but my guess would be under the dash. find that see what you can do to get it dry.
06-24-2007 12:27 PM
Levinoss Why take the top fully out of ur rig? NOOBS all of you NOOBS! jk

Yea, that was a pretty crazy rain storm kda, like everyone said give it some time. Your radio might be fried =(

~Lev
06-24-2007 09:19 AM
NalinMFG my jeep caught caught in a 3-4 hour downpour yesterday without the top... so far i have the rapid turn signal noise. i'm going to let it all dry out and go from there. rain blows.
03-28-2007 09:26 AM
erickpl I wish Alpine would do a marine radio...
03-27-2007 08:47 PM
crafty
Quote:
Originally Posted by mmasuperman12 View Post
i got caught in like a 45 minute downpoor this summer, just rode it out no real problems especially since i tossed a marine CD player in the jeep
Marine CD player and speakers was one of the best purchases I made also. That and a squegge for the inside of the windsheild
03-27-2007 03:05 PM
mmasuperman12 welcome to the gettin caught with your top down club, i got caught in like a 45 minute downpoor this summer, just rode it out no real problems especially since i tossed a marine CD player in the jeep
03-27-2007 02:45 PM
1BLKJP Yeah, give it a few days to dry everything out in the sun. I've had all of that happen before also in some serious rain. Who knows all of the places that water can get to when there's enough of it.

It does suck at like 2 am when the damn horn starts going off though.
03-27-2007 02:19 PM
erickpl Replacing the clockspring involves pulling off the steering wheel. From what I have seen, it is a fairly easy fix, but I haven't personally done it, so can't completely address it.

Give it a day or so to finish drying unless you can park it in the sun with a breeze going. It is sounding like the stereo got wet as water went down the windshield to the back of the stereo.
03-27-2007 02:16 PM
kdaebi
Ok then....

I located the fuses and blew the area out with compressed air. I did NOT remove any of the fuses. The area seemed dry.

The rapid ticking noise has stopped, but still no radio or cruise control. Is a 'clock spring' something I can replace myself? I did a quick search on the internet, and I'm not sure that I'm up to the task.

I'm not much of a mechanic, although I'm proud to say that I recently replaced a water pump and serpentine belt on my daughter's 1991 Buick LaSabre. The guy at the auto parts store said that the job would take a good mechanic about forty minutes. I joked that it would probably take me about four hours. It took six.

Thanks for all the feedback. I'm glad I found this place.
03-27-2007 01:43 PM
erickpl Sounds like the clock spring is toast. This is the item in the steering column that connects the electrical on the column with the rest of the Jeep.

Let EVERYTHING dry out. Blow out the fuses with compressed air. You may need to replace the clock spring, but if it all dries out well, it may be okay.
03-27-2007 12:01 PM
Odhinn Theres always a possibility of damage when water and electricity mix. Best bet, IMO, let it all dry out then diagnose it and see.

BTW I know exacly the rain storm you were in. I got home before it hit. With the amount of rain that fell it would be like submerging the jeep so it was definately an extreme situation.
03-27-2007 11:48 AM
whitebuffalo go to the fuse panel and pull the fuses and blow out with compressed air. your radio may be fried, as they dont like water. for the horn, id suspect the horn switch has water in it, but it could be anywhere.most of it will most likely dry out and be ok. i ahve no idea how cruise works on a jeep tho so i cant even specualte there....

fwiw, i usta carry a tarp around under my seat just in case (i have no top) but have gotten it soaked a few times before without major incident (including sunday night) of course, i have no carpet and half my wiring is ghetto anyway, so ur results may vary....
03-27-2007 11:29 AM
kdaebi
Got caught in a downpour..now I have problems...

About a week ago, I bought a 1999 Jeep Wrangler. I immediately removed the top and put it in my garage. It never rains in Texas...right?

Wrong.

I got caught in a major downpour on my way home from work last night. I mean, it POURED. I got completely soaked, and so did the inside of my jeep. I wasn't worried, because I thought that Jeeps were designed for this type of thing. Was I wrong?

Evidently.

I put the Jeep in the garage. In the middle of the night, the horn went off. I disconnected the battery cable, and went back to bed. This morning, I reconnected the battery cable (the horn didn't go off when I did this). Now I have a plethora of problems.

The radio, which worked for a bit this morning, no longer functions. The horn won't work. The cruise control doesn't function. And I hear a rapid 'tick tick' noise like the turn signal except faster, that stops when I apply the breaks or turn signals. The headlights and turn signals work fine.

Obviously, I got something wet that isn't supposed to get wet and things are shorted out.

My question is this..did I do permanent damage, or will things eventually dry out and function once again.

Any help would be appreciated, especially since my lovely wife advised against this purchase and will sieze any opportunity to rub my nose in a mistake.

Kurt
Flower Mound, Texas

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:52 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC