Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Solution to Check Engine Lights and also Gas Gauge Broken :(

Join Wrangler Forum Today


Thread: Solution to Check Engine Lights and also Gas Gauge Broken :( Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-03-2011 08:28 AM
JeepAddOns-Chris For the gas gauge thing, if you're lucky you can remove the gauges, clean the input ribbon strip, reattach and it may work correctly again. If you're unlucky, the fix means dropping the gas tank.

x2 on a PCM reset.
01-03-2011 08:24 AM
Slavisa thanks for a quick reply! i have not tried that but i can give it a go and post the results here!
01-03-2011 08:19 AM
60mg just for giggles, have you tried a complete power cycling (remove the battery for a few min)? it does look like ECU glitch to me but I might be wrong on that.
01-03-2011 08:08 AM
Slavisa
Solution to Check Engine Lights and also Gas Gauge Broken :(

Good Morning WF

I had a awesome surprise on my way to work this morning, so i leave my house and i get on the highway, in the middle of one of the hills my jeep (YJ) starts loosing power and no pedal response! So even tho my gauge was telling me i have 1/4 left, i ran out . I had about half a gallon in the back of my jeep that helped me get to the gas station but i would like to know if anything can be done (without replacing the fuel pump etc..) and if not ill just have to use the odometer now that i know the problem is there?


My Engine check light is on with the following error codes:

Code Description 12 Direct battery input to PCM was disconnected within the last 50 key-on cycles. --> Will go away
13 No difference recognized between the engine MAP reading and the barometric (atmosphereic) pressure reading at start-up --> ?
14 MAP sensor input below minimum acceptable voltage.
or
MAP sensor input above maximum acceptable voltage. --> For this, i noticed after riding the jeep and hitting bumps in the road, i would check under the hood and the airflow tube that goes from the Air Filter box to the top of the throttle body, will come off on the air filter side. Any effects this would cause??
21 Neither rich nor lean condition detected from the oxygen sensor input.
or
Oxygen sensor input voltage maintained above the normal operating range. --> Replace the Co2 sensor or im off?
33* An open or shorted condition detected in the A/C clutch relay circuit. --> the jeep has heat blowing now so the heat is working fine!
51 Oxygen sensor signal input indicates lean air/fuel ratio condition during engine operation. --> Replace the Co2 sensor or im off? 52 Oxygen sensor signal input indicates rich air/fuel ratio condition during engine operation.--> Replace the Co2 sensor or im off?



Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:48 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC