Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > fuel pump question

Join Wrangler Forum Today


Thread: fuel pump question Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-26-2007 06:27 PM
bluegrass107 I just completed a rebuild of the top half of the engine and even though the carb sat for 10 months its only 2 yrs old. I just tried to turn it over but I need to charge up the batt a little. I want to make sure that it is turning for sure. thx for all the input.
06-26-2007 06:05 PM
penguin_in_a_cj yes even with it not running there is a little pressure thus the reason pumping the gas on an old truck works.. I would check and see how much fuel you have going into your carb and if your good there start suspecting something with your carb... a poping could of been a backfire through the intake and caused all sorts of problems in there
06-26-2007 05:59 PM
bluegrass107 So is there a some amount of residual pressure on the line at the carb normally- cuz when I moved my throttle linkage I was getting a little fuel even when the engine not running. And yes I do have a filter between the pump and the carb.
06-26-2007 05:45 PM
penguin_in_a_cj you should have pressure from the outlet side of the fuel pump to your carb if you have a filter in that line then yes.. if not then pre pump you should not. if you have pressure there then it would be from the tank. you will not have pressure at the filter at the back unless you have an electronic fuel pump.
06-26-2007 05:41 PM
bluegrass107 penguin are you talking about the fuel line back by the filter (rear driver side tire) area? I should have pressure there; from the fuel sending unit - correct?
06-26-2007 05:39 PM
penguin_in_a_cj ya they are usally easy to do just make sure that the arm on the back side is resting on top of not below the metal if it is hard to put on and the bolts don't want to tighten its problelly not right.. it should be as easy as an valve cover.
06-26-2007 05:23 PM
1BLKJP
Quote:
Originally Posted by payj90 View Post
the 90 yj 258 has a machical fuel pump, to pump fuel it must be turning over. Just follow the gas line from the carb to find the put its on the passenger side of the block. i have a 90 with the 4.2 and a weber so if you need me to refrence something from that feel free to ask. hope i can help
Duh, my bad. I was thinking FI.
06-26-2007 04:57 PM
bluegrass107 Yes thats where I was thinking it would be - and the day before the ride died I had tightened the pump, cause I saw some dampness below it. I didn't torque it hard but I heard something kinda click right as it died. Got to be the pump! Have you ever had to replace one?
06-26-2007 04:54 PM
penguin_in_a_cj pull the line back and if you have a fuel pressure gauge put it in line.. if not get a empty bottle of water and if it takes longer than five seconds to fill over half the bottle then you have a volume problem, if you have good pressure and volume, try unhooking the line right before the mechanical pump and blowing air backwards through it if it starts up you have an obstruction. if not then mabye your syphon tube is broke
06-26-2007 04:43 PM
payj90 the 90 yj 258 has a machical fuel pump, to pump fuel it must be turning over. Just follow the gas line from the carb to find the put its on the passenger side of the block. i have a 90 with the 4.2 and a weber so if you need me to refrence something from that feel free to ask. hope i can help
06-26-2007 04:17 PM
bluegrass107 Not a drop of fuel and I of course can see that through the butterfly on my weber. As for the pump not sure? Whats the sound and where? newbe on this fix.---thx


BTW been thru Arizona back when I was stationed in San Diego some cool sights for sure.
06-26-2007 03:02 PM
1BLKJP So basically you are getting no pressure at all right? When you turn the key to the on position can you hear the pump at all?
06-26-2007 02:56 PM
bluegrass107
fuel pump question

My 10 month overhaul of my 90 yj I6 258 is complete but it seems that I have one last hurdle. I have lost my fuel. I'm not getting any fuel to my weber at all. I have plenty of fuel in the tank. My newly overhauled jeep ran ok for 2 weeks but with a little miss that I could not clear. Driving home the other day it just stopped--dead couldn't get it going again(fortunatly I was 20 ft from driveway) Thought maybe it was the coil but I'm getting plenty of spark. It makes sense to be the pump though cause it sat without gas in the tank for 10 months. I've searched the threads but no real good data found. How could I be sure that its the pump / and whats the best replacement.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:47 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC