Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Clutch Wierdness in an o1

Join Wrangler Forum Today


Thread: Clutch Wierdness in an o1 Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-02-2007 04:00 PM
Triple88a it wont leak outside.. it leaks internaly so you wont be able to tell. Have some one press the clutch to see if the fluid level in the canisher goes down. If it does than have that person hold the clutch down and see if the fluid goes back up while they are holding the pedal down. The leak is internal. Seals get worn out and it starts to leak past the piston cups.
07-02-2007 10:44 AM
grnorris99 I checked the slave; no leaking, but no bleeder valve either. I am guessing that the master and slave are designed as a closed system for this model tranny. My luck. The only thing I can see is to pull the hydraulic system and bench test it. Thing is, if i'm doing that, I might as well replace it. The system can't be that much money. I don't understand the closed system with an open reservoir for fluid...very odd. The Haynes manual was totally useless on this. I should have expected that as they don't keep up with changes and just keep publishing. I also found out that manual tranny parts aren't covered under warranty anyway. Problem is, I am stuck with very limited tools and no jack stands and only a marina parking lot to do the work. Thanks for all your input on this. Very helpful indeed.
07-01-2007 10:42 AM
bluvikng Try looking at the hydraulic slave unit for your clutch. Sounds like it is time for it to be replaced. Should be apparent by fluid leaking.
07-01-2007 09:09 AM
Triple88a I'm with odhinn. You press it and then as you hold it fluid is leaking past the seals back into the cup acting like you're letting the clutch up.
07-01-2007 07:26 AM
Odhinn You could also have an internal leak in the Master (internal seals in the beginning stages of failure).
06-23-2007 08:00 PM
jjseel Sounds like a little air in the lines, have you bled them?
06-23-2007 07:45 PM
grnorris99
Clutch Wierdness in an o1

This is really strange and it's beginning to piss me off. Normally the clutch operates fine. If I sit in neutral or any gear with the clutch in, eventually it seems like the clutch is engaging anyway. I could be at a stop light with the pedal depressed and the shifter in first; the car will start to roll forward as the clutch engages (pedal still fully depressed). I can't pull the shifter out of gear. When I can actually leave the stop, the clutch operates normally when it's next used. Anyone ever see this? Is it the master or slave leaking and losing hydraulic pressure? The fluid level is fine, no visible leaks. It's quite odd. I never experienced anything like this. The longer the pedal is in, the more the clutch re-engages. Seems like a loss in pressure to me. I just bought the Jeep used and am on a 3 month warranty. I want to figure out the problem, but i'm holding out for the work to be done under warranty. The problem is that I can't get to the dealer that sold me the car for another 2 months...still within the warranty time. Any insight to this would be most helpful.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:04 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC