Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > 2010 JK PCM update

Join Wrangler Forum Today


Thread: 2010 JK PCM update Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-07-2011 11:28 AM
capo1000 UPDATE.............Now the dealer doesn't feel the problem is remote starter related. They disconnected it, tried again and they still cant get the flash/update to load onto my PCM.
He said this was the first time they loaded this flash, so Im thinking this may be a brand new update....Just be careful and ask about it if you guys are going in for service in the near future.

Hope this gets solved soon
04-07-2011 07:29 AM
capo1000 Hey guys,

I just had my 2010 at the dealer this past Saturday for oil change. Came to p/u and they told me they attemted to do the flash update....But it "didnt take", and they had to wait until Monday to contact Chrysler for help.
They were sincere and gave me a loaner....Figured sh** happens and they would take care of it.
latest update is they got a new ECU from Chrysler, put it in, same thing happened. They called Chrysler and the tech asked the dealer if i had a aftermarket remote starter or alarm .....and I have a remore starter. Well, this guy told the dealer that the remote start if affecting the update.
So the dealer called the guy who installed my starter to try to work this out.
I spoke to the starter install guy yesterday after he talked to the dealer.....I've known this guy for a long time and he claims to have NEVER run into this before.
So the question is......Has anybody who has had this flash done have a remote start?

Thanks,
Bill
04-06-2011 10:29 PM
markg018
10-066

pics of bulletin.. if anyone can't see it i can scan to pdf. just didn't have access to my scanner at the time.
04-06-2011 09:52 PM
markg018
Quote:
Originally Posted by markg018
Just looking through this here.. got an oil change back on Feb 5th.. have the service bulletin right here... RRT 10-066 pcm reprogram is to correct problem with O2 sensors. Will take pics of bulletin and post.
Have to double check models but mine is a 2010 unlimited sport,with auto tran
04-06-2011 08:02 PM
markg018 Just looking through this here.. got an oil change back on Feb 5th.. have the service bulletin right here... RRT 10-066 pcm reprogram is to correct problem with O2 sensors. Will take pics of bulletin and post.
04-06-2011 05:23 PM
Weed Hopper If anyone is following this thread, I've been thru 2 tanks of gas since the pcm update was done and see no noticable difference in mpg. Like I posted before, the only thing I've noticed from the update was the compass response.
03-27-2011 11:06 AM
ESP
Quote:
Originally Posted by Salo View Post
I do all my maintenance myself so besides the BS the dealership might pitch me on (clean TB, flush coolant, blah blah blah) when I bring it in for K13 brake recall, do they normally run VIN to see if there are other recalls or updates or do I have to mention them specifically?
They can run your VIN to see all available recalls or updates for your Jeep. The PCM flash if your wondering was only for 2010 JKs made between a few months of production. Your 2008 Sahara shouldn't be included for that one.
03-26-2011 07:19 PM
Salo I do all my maintenance myself so besides the BS the dealership might pitch me on (clean TB, flush coolant, blah blah blah) when I bring it in for K13 brake recall, do they normally run VIN to see if there are other recalls or updates or do I have to mention them specifically?
03-26-2011 04:58 PM
MTH
Quote:
Originally Posted by Salo
Going in thu 3/31 for k13 brake recall...how do I tell them to look for the PCM update?
Just ask them to look for any RRTs, including 10-066. It'll pop up with your VIN.
03-26-2011 04:42 PM
Salo Going in thu 3/31 for k13 brake recall...how do I tell them to look for the PCM update?
03-26-2011 01:32 PM
Weed Hopper I took my Sahara in today for an oil change and tire rotation. When I went to pay they said they also did a flash upgrade on the pcm. From the paperwork:

PERFORM RRT 10-066 RAPID RESPONSE
REPROGRAM PCM TO LATEST REVISION
BILL CODE - W
181906H5 REPROGRAM PCM

Has anyone figured out exactly what this upgrade addressed? The only thing I noticed right off was the compass responds to direction changes alot faster. I track my mileage and maintenance with software, I'll let you know if I see a difference in mpg in the future.
02-25-2011 08:13 AM
ESP ^ best avatar ever.
02-25-2011 04:55 AM
jeffk42
Quote:
Originally Posted by SeaComms
By ECO light, do you mean when pushing the button and swapping between displays and one that says ECO and ocasionally ECO ON? Thats the only one I have, on a March 2010 buillt petrol 6 speed.
Yes, when ECO mode is on, it should start telling you when you are driving in a fuel-saving manner. Unless you have a 2010 manual with the update, apparently.
02-25-2011 04:46 AM
SeaComms By ECO light, do you mean when pushing the button and swapping between displays and one that says ECO and ocasionally ECO ON? Thats the only one I have, on a March 2010 buillt petrol 6 speed.
02-24-2011 07:10 PM
John412 Just to throw this in. MY JK was built in 6/2010 as a 2010 and does not have the ECO light function, just the MPG read out. I too find the 1-2 shift tough, typically when its cold.
02-24-2011 06:47 PM
ESP
Quote:
Originally Posted by jeffk42 View Post
Yeah, I'm sure I'm not in the list since its a 2011. I just think it's interesting that the ECO light problem was fixed for 2011, and yet the "fix" for 2010 is to turn it off. Why not just reprogram it to work like the 2011?
Agreed but I wouldn't use it.
01-21-2011 09:54 AM
jeffk42
Quote:
Originally Posted by MTH View Post
As I understand it, it's a software problem, so my assumption is that they fixed that little bit of programing before manufacturing the 2011s. Still, you could have your VIN run anyway to see if it applies.
Yeah, I'm sure I'm not in the list since its a 2011. I just think it's interesting that the ECO light problem was fixed for 2011, and yet the "fix" for 2010 is to turn it off. Why not just reprogram it to work like the 2011?
01-20-2011 08:44 PM
MTH
Quote:
Originally Posted by Pat@FieldsJeep

My user name is now Pat@FieldsJeep, and yes I copied Geoff at bestop. Thought it was just a little more professional.
Good to know, thanks. Probably for the better, given that if we ever meet in person I'd have a near irresistible urge to call you "Pato".
01-20-2011 08:01 PM
pat@fieldsauto.com
Quote:
Originally Posted by MTH View Post
Good question--remember it's not a recall, it's an RRT. It won't show on any Jeep website I know of, but you might know of one I don't. Pato is the one who told me I was due for the update when he was looking up something else for me.
My user name is now Pat@FieldsJeep, and yes I copied Geoff at bestop. Thought it was just a little more professional.
01-20-2011 07:58 PM
ESP yeah man I'm leaning more towards just putting 33's on but I've got 3.21 gears and enjoy such great MPG that it may give me a heart attack to go so large. At the same time, would be really good to see my rig sitting on 33 duratracs or KM2s....mmmm new tires.
01-20-2011 07:52 PM
MTH
Quote:
Originally Posted by ESP123
So uh MTH..."cough" "cough" when you gonna sell me your tires and get some bigger ones? "cough"
Bwah-hah-hah! They've got almost 10k on 'em now--not quite as burly as they once were. I'm going for 33s next, but I don't think you'll want them by the time I'm done. I've always assumed there were like dozens of Rubi pull offs on Craigslist at any given time . . . not true?
01-20-2011 05:55 PM
ESP So uh MTH..."cough" "cough" when you gonna sell me your tires and get some bigger ones? "cough"
01-20-2011 03:10 PM
MTH
Quote:
Originally Posted by firehawk_1989
Dealer refuses to do it.
Ran your VIN and says you don't need it, or won't run your VIN at all?

Quote:
Originally Posted by SilverFun

MTH, you described it exactly the way it feels now that i had mine done !


Quote:
Originally Posted by jeffk42
I wonder why later JK's like the 2011's aren't included if this is the case. The tranny and engine are the same.
As I understand it, it's a software problem, so my assumption is that they fixed that little bit of programing before manufacturing the 2011s. Still, you could have your VIN run anyway to see if it applies.
01-20-2011 02:54 PM
jeffk42
Quote:
The customer may notice that the fuel saver indicator light (FSI) is turning on and off. This engine and transmission combination on the vehicle was not designed to operate the FSI light as intended.

Updating the PCM software will turn off the FSI light, which will correct the conditions listed above.
I wonder why later JK's like the 2011's aren't included if this is the case. The tranny and engine are the same.

Whatever the problem was in 2010 that made it useless (based on an earlier ECO light thread), it's not the same for 2011, so hopefully I won't see my ECO light disappear after an update some time down the road....
01-20-2011 02:21 PM
SilverFun
Quote:
Originally Posted by MTH View Post
I've now driven around town several times since the flash with my manual transmission.

I'm really, really surprised by the results. Previously, I'd had a mystery "hitch" shifting to second. Sometimes the gear would even grind a bit before it set in, or I'd have to double clutch or pause in neutral for a second or two before shifting to second from first. This felt like a mechanical/synchronizer problem to me, so I figured the flash wouldn't fix it.

I was incorrect--it's now as smooth from first to second as it is in every other gear. Really surprising. It also feels a bit peppier taking off from stops, but that may just be because I can shift more smoothly.

Whatever the case, if you've got a 2010, I highly recommend you call your dealer and have them check to see if your VIN is up RRT 10-066.
MTH, you described it exactly the way it feels now that i had mine done !
01-20-2011 01:56 PM
ESP
Quote:
Originally Posted by firehawk_1989 View Post
Dealer refuses to do it.
Go to another dealer and have them run your VIN to see if your Jeep can get it.
01-20-2011 12:54 PM
firehawk_1989 Dealer refuses to do it.
01-20-2011 12:16 PM
ESP From the dealer:

Service Bulletin

This bulletin applies to all JK veheicles equipped with a 3.8L engine (sales code EGT) and a 6 speed manual transmission (sales code DEH) built before April 16th, 2010 (MDH 0416XX).


He's wrong. The update is for manual Jeeps but I beleive some autos have gotten flashed too. Look into it at another dealer location.
01-20-2011 11:58 AM
phottomatt Hmmm, just called my dealer, he said that update was for the autos only. But I don't have much faith in my dealership service department, I'm going to try a different dealership next time I need something.
01-20-2011 10:46 AM
MTH I've now driven around town several times since the flash with my manual transmission.

I'm really, really surprised by the results. Previously, I'd had a mystery "hitch" shifting to second. Sometimes the gear would even grind a bit before it set in, or I'd have to double clutch or pause in neutral for a second or two before shifting to second from first. This felt like a mechanical/synchronizer problem to me, so I figured the flash wouldn't fix it.

I was incorrect--it's now as smooth from first to second as it is in every other gear. Really surprising. It also feels a bit peppier taking off from stops, but that may just be because I can shift more smoothly.

Whatever the case, if you've got a 2010, I highly recommend you call your dealer and have them check to see if your VIN is up RRT 10-066.
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:51 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC