Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   electrical problem (http://www.wranglerforum.com/f210/electrical-problem-1021.html)

stu 01-29-2006 04:47 PM

electrical problem
 
i seem to have lost the earth connection to the dash board gauges.....all of them.

well im guessing its earth problem because if i hit bump they will flick on and tell me my revs, speed, fuel amount and etc but it may only last 30 seconds before all the gauges show nothing again..

Am im right in my diagnostics? i need to know from anyone who had, found and fixed this problem how to do just that.

Jerry Bransford 01-29-2006 06:47 PM

The TJ's instrument panel has two big multi-pin connectors immediately behind it that work loose and cause that problem. Remove the instrument panel, it pulls straight out after 8-10 screws. Once out, take each male pin and give it a tiny pinch with needlenose pliers to very(!) slightly flatten each pin so it will make a better contact into its female mate. Once done, this should cure the problem pretty much forever. I did this to my TJ nearly 9 years ago when it was still nearly new and it fixed it completely.

This fix is very commonly done, no worries. :)

stu 01-29-2006 07:17 PM

you champion! cheers mate.

kbart 01-29-2006 09:04 PM

Interesting, do they call ground earth down under?

stu 01-30-2006 12:33 AM

yes..... id say so, as i commonly hear something described as being "earthed" as apposed to "grounded to or just ground to"

"ground" has been used as the past tence of grind.....as in "that hunk of steel was ground down to suit" blah.

stu 01-30-2006 12:37 AM

might has to start an USA to AUS translations thread!
:D


All times are GMT -5. The time now is 02:41 AM.