Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   RPM problem (http://www.wranglerforum.com/f282/rpm-problem-105887.html)

we.go.ride.808 08-04-2011 06:04 PM

RPM problem
 
my 04' has been having problems with the RPMs. when in neutral the rpms sway between 400-750rpms, like constantly moving up and down. a few times it got so bad it has stalled while sitting at stop lights. i am not the most knowledgeable person about engines, if you have any ideas on what the problem is, please let me know. thanks.

necromancer_tat 08-04-2011 07:29 PM

Quote:

Originally Posted by we.go.ride.808 (Post 1439423)
my 04' has been having problems with the RPMs. when in neutral the rpms sway between 400-750rpms, like constantly moving up and down. a few times it got so bad it has stalled while sitting at stop lights. i am not the most knowledgeable person about engines, if you have any ideas on what the problem is, please let me know. thanks.


Any check engine lights? Are you running the ac when this happens? How well does it run when you aren't stopped?

NHWRANGLER 08-04-2011 11:18 PM

new throttle return springs.

we.go.ride.808 08-05-2011 09:40 PM

Quote:

Originally Posted by necromancer_tat (Post 1439701)
Any check engine lights? Are you running the ac when this happens? How well does it run when you aren't stopped?

the check engine light comes on quite often. but i held the dash button and turned the car on, (so it would give me the code to whats wrong) and it says "no faults" each time. then i tighten my gas cap and it goes away soon after. and no, i never run a/c in my car. and it runs fine, the only times i have problems is when im stopped.

C.L. 08-05-2011 09:46 PM

With an '04 you don't hold the trip reset. Just turn the ignition on and off 3 times in 6 seconds (ending with on) without starting it. The codes will display in the odometer area. My idle was acting up at stoplights just before the TPS failed. Replacing it cleared the codes and smoothed out the idle.

I've also heard people say cleaning their IAC cured rough idle.

MikeMTJ 08-06-2011 02:11 AM

Quote:

Originally Posted by C.L.
With an '04 you don't hold the trip reset. Just turn the ignition on and off 3 times in 6 seconds (ending with on) without starting it. The codes will display in the odometer area. My idle was acting up at stoplights just before the TPS failed. Replacing it cleared the codes and smoothed out the idle.

I've also heard people say cleaning their IAC cured rough idle.

x2

MikeMTJ 08-06-2011 02:14 AM

Quote:

Originally Posted by we.go.ride.808
my 04' has been having problems with the RPMs. when in neutral the rpms sway between 400-750rpms, like constantly moving up and down. a few times it got so bad it has stalled while sitting at stop lights. i am not the most knowledgeable person about engines, if you have any ideas on what the problem is, please let me know. thanks.

Read through this:
http://www.jeepforum.com/forum/f9/lo...topped-961477/


All times are GMT -5. The time now is 06:20 PM.