Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   94 yj shakes on acceleration in all gears (http://www.wranglerforum.com/f218/94-yj-shakes-on-acceleration-in-all-gears-107056.html)

5288dan 08-11-2011 05:59 PM

94 yj shakes on acceleration in all gears
 
I have a 94 yj and just in the last couple days it started to shake while accelerating in all gears the higher the gear the harder it shakes and the harder you push the gas peddel the harder it shakes. It goes away when I release the gas or push in the clutch. Its not just avibration the whole jeep shakes when it happens. Any one have any answers for me??

draarong2004 08-11-2011 06:51 PM

either a cylinder isn't firing, or you have a broken engine mount...

5288dan 08-11-2011 07:22 PM

it runs good while idleing it only shakes when im accelerating and stop wen i let off the gas or push cluth in.motor mounts looked pretty good so did the trans mounts. the rear drive shaft has a little play in it. would that be the issue?

onroad 08-11-2011 07:27 PM

It doesn't shake when you rev it in neutral, only when putting power to the ground? If you feel play in a u-joint definitely replace it. At least drop the driveshaft and wiggle all the u-joints, sounds like one might be binding up.

5288dan 08-11-2011 07:45 PM

i also forgot to mention the trans was rebuilt about 3,000 miles ago dont know if that could be a factor. and yes only wen accelerating.

draarong2004 08-11-2011 09:49 PM

i'm still leaning towards engine failure of some sorts, when was the last time you checked the plugs? could be dirty injectors, did you check the engine mounts yet? it could be a u joint but that'd still make some sorta "shake" just maintaining speed or slowing down....especially slowing down with engine "braking"

5288dan 08-11-2011 09:51 PM

if anyone else has any ideas please feel free to extend your olive branch of knowledge. it would be greatly appreciated. thank you...

5288dan 08-11-2011 09:56 PM

it shakes as long as i have my foot on the pedal not as much while maintaining speed as it does accelerating but very little while down shifting or engine braking. i dont have the jeep with me so i cant check these thing right now but hopefully within the next couple days ill be able to take a look at it.. again it started only a few days ago out of now where and is greating worse little by little every day.

Garyk 08-12-2011 07:38 PM

Quote:

Originally Posted by draarong2004 (Post 1462577)
i'm still leaning towards engine failure of some sorts, when was the last time you checked the plugs? could be dirty injectors, did you check the engine mounts yet? it could be a u joint but that'd still make some sorta "shake" just maintaining speed or slowing down....especially slowing down with engine "braking"

When was the last tuneup? Is it a shake or a bad vibration. Like mentioned too, check the u-joints...

2xs 08-12-2011 08:18 PM

IMO: Bent driveshaft.
bad U-Joint?

draarong2004 08-12-2011 08:57 PM

Quote:

Originally Posted by 2xs (Post 1465382)
IMO: Bent driveshaft.
bad U-Joint?

if it were a bent driveshaft it'd shake more than just accelerating....and it wouldn't change when letting off the throttle...almost thinking the same for u-joints for him

2xs 08-12-2011 09:28 PM

Quote:

Originally Posted by draarong2004 (Post 1465476)
if it were a bent driveshaft it'd shake more than just accelerating....and it wouldn't change when letting off the throttle...almost thinking the same for u-joints for him

It would be worse upon accelerating, when there is power behind it.

trust me, I have bent drivelines on rocks and that is the result.

jk'n 08-12-2011 11:24 PM

If you haven't been wheeling it and the problem just appeared, I would lean u-joint.

5288dan 08-15-2011 11:45 PM

thanks. i think its u joints myself.thanks for the help. i dont have jeep right now. will be able to take a look sometime this week and ill update my findings..


All times are GMT -5. The time now is 07:12 AM.