Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   throttle issue?????? (http://www.wranglerforum.com/f282/throttle-issue-107093.html)

laxkingin205 08-11-2011 09:18 PM

throttle issue??????
 
hey guys,
Im a new member so be gentle. This is an awesome site, so I figured who better to ask then the jeep lovers. First off I will tell you what I have and what I've recently done to it. I have an 03 jeep wrangler se 4 cylinder 2.4L 5 speed manuel with 54,xxx miles. I have recently replaced the spark plugs and wires, changed the oil and oil filter, changed the air filter, and last replaced the throttle control sensor. Now for the issue that I hope you guys can help out with. It started out as just annoying check engine light. I ran the code and it said throttle position sensor was having issues. So after ignoring it for a few weeks, I finally went to the dealer and bought the oem tps. As soon as I installed it, everthing went to junk. Every stop sign I stop at the engine dies. When im accelerating, I'm being bucked around and jerked about. I then tried to put the old one back on, but it continued to do the voilent jerks. So I took it to a buddy who is a mechanic and he kept it for a few days. He ran a few test, replaced the idle sensor, and said it was fixed. He said that it wouldn't buck, but the check engine light would still be on. Well the first road I got on after I left the shop, it starting bucking again. So I took it back. He put the "Big computer up to it". long story short he thinks its a bad computer. When he hooked the computer up, it say its idling at 48%, but when he revs it it only changes by 1%. So I took it to a second mechanic, and he kept it for a few days. I thinks its a bad throttle body. Sorry guys for the 100 page book, but I figure the more information the better. What do you guys think, bad computer? bad throttle body? or something else?
thanks a ton!!!!!

James249G 08-12-2011 07:13 AM

I would start by checking your Idle Air Controller. If its an 03, there's a chance it could just use a good cleaning. That's the CHEAPEST possible answer. As for your computer, sometimes after replacing your TPS or IAC it takes a while for your ECU to "re-learn" and re-set itself. If that's not happening, it MAY be the problem.
Good luck, bro.

Indy 08-12-2011 06:41 PM

Try resetting your computer. Leave the battery disconnected overnight to completely erase the memory. See if that helps.

Wyominer 08-12-2011 06:46 PM

Welcome to the forum! Also welcome to the world of Jeeps! Can't help ya with your problem, but the resetting the computer can't hurt.


All times are GMT -5. The time now is 08:28 PM.