Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Issues after rain w/o top on, help needed (http://www.wranglerforum.com/f282/issues-after-rain-w-o-top-on-help-needed-107784.html)

Pmedg 08-16-2011 08:38 AM

Issues after rain w/o top on, help needed
 
Last weekend I forgot to put the top up and it rained. I didnít think it would be an issue but since getting wet I have been having some issues that have continued long after the sun dried everything out.

First the horn went off all on its own when the car was off and eventually I pulled the wire to it and it smoked and Iím assuming shorted out, should be easy to replace.

Also when the jeep has been sitting it wont start right away, usually takes 2 turns of the key, and when it starts rev's to 2k RPM then comes back to idle.

When driving in what I think is 2nd gear around 2k RPM it will flutter until i push through it and the check engine light is on.

I havenít had a chance to have the codes pulled but Iím hoping it isnít a major issue. I'm assuming it was the rain and not a freak coincidence, but I didnít think rain would cause a problem outside of wet seats/carpets. If anyone has any ideas i would appreciate it. Thanks in advance.

InfernoGirl 08-16-2011 09:04 AM

I'm gonna guess that your clockspring got wet and is on it's way to failure. I may be wrong tho'. Someone else will chime in and verify or deny my instinct.

Pmedg 08-16-2011 09:56 AM

interesting, never heard of a clockspring. how would i go about checking to see if that was the case? also would that affect just the horn or would it also cause the weird fluttering of the engine around 2k RPM as well?

kjeeper10 08-16-2011 10:01 AM

Horn, airbag light on- and loss of cruise control I believe go, all three symptoms of a bad CS.

It is behind the steering wheel and allows contact for the electrical parts when the wheel is turned left & right.

My was bad before I traded the jeep away :(

Pmedg 08-16-2011 11:05 AM

havent had an airbag light come on and i dont have cruise controll its a 98 sport. but the check engine light came on and it feels like power comes in and out around 2000 RPM and it takes two times to start, when before it would always start on the first try.

kjeeper10 08-16-2011 11:21 AM

Probably a separate issue. Def get the codes checked, could be a slew of things.
higher miles?

Pmedg 08-16-2011 12:00 PM

44k, so very low for the year

kjeeper10 08-16-2011 12:29 PM

Very common especially on an older Tj was the anti drainback valve near the fuel pump to fail. There is a trick to work through the problem and I think turning the key twice like you said is part of it.
Google it-- you find some more info :)

Pmedg 08-16-2011 12:38 PM

excellent thanks for the info, i will look into it

kjeeper10 08-16-2011 12:41 PM

Jerry B has a write up on replacing his.
Looks easy if that is your problem :)

Pmedg 08-16-2011 12:56 PM

i hope that its inexpensive, i will have to take a look at it. just got back from vacation and hopefully get to check it out this weekend.

kjeeper10 08-16-2011 01:14 PM

Quote:

Originally Posted by Pmedg
i hope that its inexpensive, i will have to take a look at it. just got back from vacation and hopefully get to check it out this weekend.

Good luck.

When you getting a chance to pull the codes?

Pmedg 08-16-2011 01:33 PM

idk, it might not be until saturday, but i dont really need to drive anywhere till then either. accept down the street to get groceries. once i get them i will put them up

Always Stuck 08-16-2011 09:13 PM

Give me a call tomorrow. I'm on vacation this week.

I'm heading to R.I. in the morning to get two 350's running correctly on a boat. It's a 35 footer and runs like s**t, a row boat would pass it. I have two days of work there from what I've looked at already.

If I get out of R.I. early enough tomorrow or Thursday(For lack of parts) I'll pull your codes and we'll sort this out. If not I'll be at the shop Friday doing lifters on my daughter Grand Cherokee.

I'll also be down the shop this weekend repairing a fender on a truck (side work) and welding the back of a live floor trailer.

We just need to figure out a time that works and we'll..... GET ER DONE.



The fun never ends...................

Pmedg 08-16-2011 09:28 PM

Who is better than you!

Pmedg 09-08-2011 01:30 PM

Hopefully i am not jinxing mself but it seems as though my Jeep just needed to dry out for a few weeks. On Friday the Jeep started right up and the CEL was off. I have not had a problem all week and there is no more sputtering at 2k RPM. It took about 3 weeks to dry out completly but that seemed to do the trick. I havent had a chance to mess with the horn issue but i appreciate the input and will update when i figure out if i need to replace the clockspring.


All times are GMT -5. The time now is 05:01 PM.