Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Engine Loses Power on the Highway, Help? (http://www.wranglerforum.com/f218/engine-loses-power-on-the-highway-help-108815.html)

dan-E 08-22-2011 12:03 PM

Engine Loses Power on the Highway, Help?
 
Hey guys,

I have a '95 with the 2.5L engine that has around 101,000 miles. I was on the freeway doing about 65 when all of a sudden the engine started misfiring/lugging/surging? Not sure what to call it, exactly. Basically, it feels like the engine sputters like it is low on gas and running on fumes, so it slows down briefly before it catches again, but never completely stalls. (I had half a tank left.) I limped home by downshifting and keeping the rpms up but once I got off the freeway and drove the streets, it ran fine.

I drove it to the shop the next day (no highway) but again, the engine ran fine and I couldn't get it check out since the were close. About a week later, after no issues I ran into the same problem on almost the same stretch of freeway, except this time my tank was nearly full.

It's weird how it's fine around town but this occurred twice at 60-65. My first thought was maybe the fuel filter but I just bought this I'm no mechanic so any advice would be appriciated. Thanks in advance.

goatman 08-22-2011 02:20 PM

I would make sure the pump is in good shape first. Next would be making sure the gas cap is venting properly, not causing a vacuum in the tank.

vinni495 08-22-2011 02:52 PM

possobly your cat caonverter is piuging up ,that is a broken piece is rolling around blocking exit presure,when slowing down back presure is released leting broken piece fall down letting gasses flow again till blocked again.

Garyk 08-22-2011 06:05 PM

Sounds like a fuel issue, water??..pump or pickup in the tank???The CAT might be a thought too.

stykthyn 08-22-2011 06:33 PM

had a saturn do this. turned out the coil went bad and wasnt sending a hot enough spark to maintain highway speeds but was fine around town.

91 yj 08-22-2011 06:49 PM

all good ideas would check fuel pump pressure may not have the pressure to drive at highway speeds

dan-E 08-22-2011 11:21 PM

Thanks for all the suggestions.

SirCanni 08-22-2011 11:28 PM

It's the cat I replaced mine with a magnaflow for 60 bucks problem solved. But you need 6" of extra pipe if you go that route.


All times are GMT -5. The time now is 04:41 AM.