Jeep Wrangler Forum

Jeep Wrangler Forum (
-   TJ General Discussion Forum (
-   -   Sway Bar Question (

Buffalo97 09-03-2007 02:09 PM

Sway Bar Question
Hey everyone,

I discovered yesterday that my front sway bars are broken. The Bars separated at the ball. Now I can completley and easily fix these. I know this because I have fixed this twice already. (both sides) this will be the third time fixing them. My 97 has 109,000 and is stock. since it became my DD after I went back to college.

My question is.....Is this normal?? Not to mention the little red devil sat in the garage for a year and a half.

nicolas-eric 09-03-2007 02:14 PM

i also had this twice on my old 99 TJ. that seems to be normal.

Jma20a 09-03-2007 09:04 PM

i got a 99 with 80,000 miles and have not had that problem.

drummerwookie 09-03-2007 09:14 PM

that happened when i had my ZJ. the front ones just wore out at the ball. it happens especially if you wheel it without disconnecting them bc every time you need to articulate the front axle, it just adds extra stress to the sway bar links that wouldnt be there had it been discoed

Triple88a 09-03-2007 10:24 PM

you are talking about the sway bar links right? Get quick disconnects and be done with it. I've heard many have problems with the stock links so why buy and replace with stock when you will replace them again when they brake.

All times are GMT -5. The time now is 08:24 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.