Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ General Discussion Forum (http://www.wranglerforum.com/f290/)
-   -   New member KS need some advice (http://www.wranglerforum.com/f290/new-member-ks-need-some-advice-115512.html)

Turnerksu 09-30-2011 03:37 PM

New member KS need some advice
 
1995 replaced o2 sensor about a month ago, replaced map sensor about a week ago. Been Running rough engine light comes on with code 21 o2 sensor, since I have replace the o2 already could a bad coolant sensor throw an o2 error? Any thoughts?

183Beast 09-30-2011 07:42 PM

Hi there,

Im from Great Bend, KS myself. Just got back from Tuttle creek not to long ago. your probably not to far away if your around K-state. Welcome to the forum.

Anyway,


Tune-up or anything done recently? check your plugs, cap wires. Could be simple. Look for an intake leak or a possible exhaust leak around the header collector it could be cracked giving you a false reading at the O2 sensor.

Check your coolant for brown goo chocolate milk looking stuff. Also check your oil for chocolate milk. Possibly a blown head gasket.

Could even be bad fuel. Let us know your engine size and miles.

Turnerksu 10-01-2011 08:41 AM

Thanks for the reply, yes big k-state fans, new to the jeep world, got it to drive back and forth to work and love it. Absolutely hooked. All plugs, wires, distributor cap, distributor rotor, distributor plate and ignition coil all have been replaced. Didn't do this when I firstgot the jeep about 2 months ago, I will look into the other things you suggested today. Jeep has about 140k on miles, no oil leaks and oil looked good when I changed it. From what I been researching suggest it also could be the coolant sensor, but no engine code is flagged. Again thanks for the reply, jeep runs good enough just misses in higher gears.

Thanks

Nhaz 10-01-2011 12:15 PM

Check for vacuum leaks.

Also. Did you reset the computer? If not unhook the battery for 10 minutes.

And yes a bad temp sensor can change how the computer runs the vehicle. It thinks its cold all the time, runs it rich and the o2 reports a value that the computer thinks is wrong and throws a code.


But I would start at vacuum first.


All times are GMT -5. The time now is 03:29 AM.