Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   2012 JKUR Electrical System Problem (http://www.wranglerforum.com/f274/2012-jkur-electrical-system-problem-116145.html)

BattleRifle 10-04-2011 08:25 PM

2012 JKUR Electrical System Problem
 
We've had our Rubicon for 4 weeks now and LOVE IT!!! It did, however, recently have a serious problem. Four days ago the head lights would stay on during the day light and the dash/nav radio screen went into the night time dim mode. This was when the auto feature on the lighting multi-stick was chosen. Then the next day, the wiper would swipe once when starting the vehicle and would give one swipe every 40 seconds while the vehicle was running. Dealer checked it out and said that the TIPM was bad. For all of you that don't know, the TIPM (Totally Integrated Power Module) is the new name for the high-tech fuse box with a hidden lower layer of relays etc. The dealer was great. Got one next day delivery and had it installed by noon. I drove it home in the afternoon with an ear to ear proud grin with all of my music library at my every whim. So, although it's a pain to have a brand new expensive toy that needs repair. I still love my new Rubi. It rides great, tracks down the road great, has a quick spunky response and goes up hills like it could climb vertically if I tried. I just hope that this isn't a sign of more bad electrical issues to come. I'm glad it was replaced under warranty because I think the bill would have approached a thousand bucks if I had to pay for it.


All times are GMT -5. The time now is 05:30 PM.