Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   A/C and Heater - What Else to Check? (http://www.wranglerforum.com/f282/a-c-and-heater-what-else-to-check-120848.html)

scottunzicker 11-02-2011 05:41 PM

A/C and Heater - What Else to Check?
 
So here's what's going on: Neither my A/C nor my heater will kick in when I turn the hot/cold knob on the control unit. I know for a fact that my fan switch is out, too, but I can jumper the contacts in the plug to make the fan come on.

With winter coming on, I'm mostly concerned about getting some heat going. I've checked the heater blower motor by hooking up 12v to it, and it worked fine (I also put 12v across the A/C compressor clutch, and it worked fine, too). The blend door actuator motor WAS seized up, but I cleaned it, hooked up 12v to it, and it's working fine directly connected to the battery. HOWEVER, when I plugged it back into its harness and rotated the hot/cold knob, the actuator didn't move. I then MANUALLY rotated the blend door all the way both left and right with the fan blowing, but could feel no hot air coming from any of the various vent settings I tried (the vent selector knob seems fine - I select floor, and air blows out the floor vent, dash vent, etc.). Looking at the A/C heater control unit from the front (fan switch, hot/cold knob, vent selector), there are three wires on the far right side. The top one is green, the other two are black. It doesn't seem to matter which order the bottom two are in when I try everything.

Here's what I'm going to try first. Since the fan speed switch is messed up, its connector pretty much melted, the hot/cold knob doesn't seem to work, and the vent selector knob is getting crusty, I'm going to go pick up a new A/C / Heater control unit from AutoZone, splice it in, and see what happens.

Any and all guidance, tips, troubleshooting steps, etc., appreciated.

Thanks!

scottunzicker 11-03-2011 01:04 AM

No? Anything?

Rubicondon53 11-03-2011 06:57 AM

My factory rotary switch for a/c went out years ago. I bypassed it, and installed an on\off toggle... If that blame stupid rotary goes out completely, I'll continue to tap into the harness and install toggles as I go.. Those rotarys are unreliable, and I'm sure they will all be dummy switches as they will continue to fail..


All times are GMT -5. The time now is 11:15 AM.