Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Starting engine (http://www.wranglerforum.com/f282/starting-engine-122550.html)

TjMiley00 11-13-2011 04:25 PM

Starting engine
 
Hello everyone I'm looking for some help with an issue I'm having with my 00 Tj it's a 4.0 standard 5 speed I have the cold air,cat back and hypertech's power programmer. When I start my jeep up (cold) it sounds like it's got a cam from hell in it after about 5 to 10 seconds it smooths right out . It will not do this if the engine is warm . And it was doing this before the install of list above . I believe it's getting to much fuel at start up . Can anyone give me some advise or help on this .

Thank you

Jerry Bransford 11-13-2011 04:35 PM

1 Attachment(s)
Have you tried cleaning the throttle body which will help get the the IAC (idle air control module) cleaned up? The IAC is what provides all (!) of the engine's air at idle and it could be sticking a tad when cold.

Use aerosol throttle body cleaner and do it with the engine running. Direct some of the spray towards the Idle Air Control Passage Inlet slot that is just above the butterfly valve plate. That will usually kill the engine when at idle but that's ok, just restart it. That air slot is the air intake for the IAC and you want to direct some of the cleaner in through that slot so it can get to the IAC.

TjMiley00 11-13-2011 04:40 PM

No I haven't tried that I'll get some tomorrow and clean it after work
Thank for you help

TjMiley00 11-15-2011 10:32 AM

Didn't work but I'm going to keep trying it for a few days longer just incase it really dirty in there


All times are GMT -5. The time now is 06:30 PM.