Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   95 YJ Fuel Pump, no power at connector? (http://www.wranglerforum.com/f218/95-yj-fuel-pump-no-power-at-connector-12431.html)

snb73 10-16-2007 02:39 PM

95 YJ Fuel Pump, no power at connector?
 
I have a 1995 Jeep Wrangler with a 2.5 4 cylinder, fuel injected.

The fuel pump isn't working. No 12VDC at the connector going to the pump.

My gas gauge is working, but the fuel pump isn't pumping. When I connect an external 12 VDC to the fuel pump, I can hear the pump working, get fuel pressure at the injector rail and the Jeep starts.

I traced the the wire ,Green with Black stripe (GRN/BLK), from the fuel tankback to the power distribution center.

All my fuses and relays look and appear fine. Any ideas?

Thanks, Steve.

captflyte 10-15-2008 11:44 AM

What did you figure out? I have same problem

chezuki 10-15-2008 01:09 PM

lol, almost exactly 1 year old...

yjwrangler 10-15-2008 01:18 PM

^boooooooooooooooooooooooooooooooooooooooooooooooo ooooooo

i hope you like high taxes and socialized medicare...anyways have a good day!!!!!!!!!!!!

The Silver Gorilla 06-06-2013 12:46 PM

^^same issue

indirocz28 06-06-2013 02:31 PM

Did you follow the wire back up front to be sure you don't have a break in it somewhere? Checked the Fuel Pump Relay?

If you need a wiring diagram, PM me.

The Silver Gorilla 06-06-2013 03:02 PM

Replaced the relay, and followed the wires back as well as i know how (this is my first time dealing with something like this).


All times are GMT -5. The time now is 08:26 PM.