Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   6 cylinder engine with the power of a 4 cylinder... (http://www.wranglerforum.com/f218/6-cylinder-engine-with-the-power-of-a-4-cylinder-124313.html)

THEJAG5 11-24-2011 07:02 PM

6 cylinder engine with the power of a 4 cylinder...
 
My 92 YJ has no power! I can't figure out why its so slow. any ideas? it is very sluggish... I thought 6 cylinder engines usually have more pwer than what mine does. my friend's 4 cylinder toyota can beat my jeep any day! why is that!?! NEED HELP!

Hectic 11-24-2011 07:10 PM

clogged cat's can cause loss of power.

XJ Knight 11-24-2011 07:13 PM

If you got larger tires with stock gears then that could be your problem..

THEJAG5 11-24-2011 07:15 PM

"cat's" ?
and im running 33s on it.

XJ Knight 11-24-2011 07:26 PM

Catylitic converter.. and yeah guessing your on stock axle gearing so the 33's are slowing you down some

bruceandjo95yj 11-24-2011 07:28 PM

Keep in mind that its a older jeep and not a race car:)
Keep tellin the wife and relatives the same thing..

THEJAG5 11-24-2011 07:35 PM

sometimes, it barely goes 55mph in 4th gear!... im not asking that much from my jeep. i just wanna be able to go 55 in 5th gear.lol

bruceandjo95yj 11-24-2011 07:40 PM

lol dam ya guess that would stink
i assume you have tried the easy stuff...plugs,plug wires and etc etc?
Could be that easy if you havent...

Hectic 11-24-2011 07:44 PM

symptoms can be

Power loss, overheating, glowing header/manifold, whistling exhaust note, missing, marble sound in cat.

Idles fine but when you reach the upper rpm range with a load ,like going up a big hill or bridge it will really bog down.

THEJAG5 11-24-2011 07:45 PM

yup. tried all the simple fixes...and my engine is still sluggish.

XJ Knight 11-24-2011 08:10 PM

my vote is decide what your final tire size is gonna be then prepare for that.. Basically rear axle swap and then regear.. Someone said cloged cat coverter earlier as well.. that is a interesting thought

banks316 11-24-2011 08:13 PM

55 mph in 4th sounds normal. I don't hit 5th till 65ish I'm running 4.56 gears with 36 13.5 swampers. Have you done a full tune up? New plugs, wires, cap, rotor, air filter, them filter? Are the plugs gapped right. They should be .035 Have you checked all the header bolts, exaust for leaks. What does the exaust smell like? If its smells like gas then it might be running rich. In that case new o2 sensor.

AKYJ 11-25-2011 01:12 AM

If you are running 33s with stock gearing that's your problem you need 4:10s minimum To get your highway speed back.

YJman 11-25-2011 07:56 AM

Most 6 cylinders came with 3.07s in the diffs (for standard transmissions). My 92 is on 33s as well. I got lucky and have 3.55 gears. To help the power I put in a high flow catalytic converter and built my own free flowing air intake. And I just maintain it the best I can.

kik 11-25-2011 11:30 AM

Quote:

Originally Posted by THEJAG5 (Post 1770062)
yup. tried all the simple fixes...and my engine is still sluggish.

Usually a clogged cat. Your's is probably over due to be replaced.

Jeeper_Kile 11-25-2011 05:46 PM

Yeah all these could be it, idk why it would be so bad because i can drive 55mph no problem in my 4cyl in 4th and sometimes 5th pending on the road

heat.YJ 07-23-2012 02:15 AM

im having the same problem once i lifted it. all my power was gone i put a new fuel filter in that helped a little bit but still can barely get up to 45 mph within in two miles so if you get something that works plz let me know


All times are GMT -5. The time now is 03:26 AM.