Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Many components stops working when using turn signal. (http://www.wranglerforum.com/f282/many-components-stops-working-when-using-turn-signal-128224.html)

MKM 12-18-2011 09:18 AM

Many components stops working when using turn signal.
 
Sometimes when I use my turn signal (at least) the following components stop working: turn sinal, wiper and radio. One time components stopt working even without using turn signal.
By turning jeep off and on again, all componets works again (crazy). I suspect it has to do with electricity; but what?

Can someone help me?
Thanks

Jerry Bransford 12-18-2011 10:24 AM

That sounds like a ground connection is missing somewhere. Have you or someone else done any work on the Jeep where one of its ground wires might not have been reconnected properly?

MKM 12-18-2011 10:36 AM

No one worked on Jeep resently. Do you think the ground is in the turn signal circuit or nearby turn signal switch?

Jerry Bransford 12-18-2011 10:55 AM

The possible weak/missing ground is more likely to be at or by one of the turn signal sockets. Check the bulbs in all the turn signal bulb sockets as well as the sockets too, bulbs and/or their sockets can cause strange problems too.

No guarantee your problem is caused by a faulty ground but as a guy who has done a lot of electrical/electronic troubleshooting over 50+ years, that is where I'd look first.

MKM 12-18-2011 12:28 PM

Could it be the switch in the key cylinder?
See: wipers,turn signals and radio not working - JeepForum.com


All times are GMT -5. The time now is 05:02 AM.