Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Weird Blinker issue..... (http://www.wranglerforum.com/f210/weird-blinker-issue-13146.html)

kuotown 11-13-2007 01:59 PM

Weird Blinker issue.....
 
I have a strange issue with my blinkers in my 2000 TJ Sport. They behave perfectly when the headlights are off but when I turn my headlights on and use my blinker to turn right they blink rapidly. Like when a bulb is out, but none of the bulbs are burnt out. I have checked all bulb connections and wire connections at each blinker and all are intact and in good condition. The left blinker behaves perfectly in all conditions so far. My Jeep has never been in a wreck. Is there something I am missing or is this a common problem with an easy fix? Any suggestions would be greatly appreciated. Thanks in advance!

dwdrums801 11-13-2007 02:07 PM

replace the bulbs .....i had a similar problem in a dodge dakota

kuotown 11-13-2007 03:43 PM

I just finished putting in all brand new bulbs. I replaced every bulb except for the headlights and I have had no luck. It still behaves the exact same way. Any other ideas? This minor issue is frustrating me as the tickets for this issue are expensive!

dwdrums801 11-13-2007 04:23 PM

you can get a tix for having the blinker blink too fast?

kuotown 11-13-2007 04:33 PM

Evidently you can b/c my gf got one in it last night.... 89 bucks! She's about to skin me alive for not having fixed it sooner. I just figured to heck with it since it blinks but the cop said she had to prove that it was fixed when she pays the ticket (or rather i get stuck paying it for her) or the fine goes up somehow. Hence the reason I'm trying to get it fixed ASAP and without taking it to a mechanic to charge me an arm and a leg.

Tj Bunch 11-13-2007 05:01 PM

Try the Flasher It amy be Bad, Usally its a bulb or the flaher when only one side does it.

kuotown 11-13-2007 05:27 PM

that idea popped into my head about an hour ago.... I've since taken apart my entire dash and steering column searching for it. Any idea where it is located? It is not in the main relay panel or the fuse box. If anyone happens to have a picture or can give me a good idea that would be great. Thanks for all the help so far!

kuotown 11-13-2007 06:13 PM

Alright I just found and replaced the Flasher. That didn't fix it either. The right side is also much more dim than the left side by the way. I hate to say this but if I can't fix this without paying a mechanic or electrical car repair shop to fix it then I will just trade it in, which I hate to do b/c I LOVE driving this Jeep so much.

RIPBiker13 11-13-2007 06:15 PM

Mine does that sometimes too! Only on the right. Replaced the bulb, and checked all connections. Every couple weeks it'll do it for the day then be normal again...:confused:

ecbuck 11-13-2007 06:34 PM

<then I will just trade it in>

You are kidding - right?:confused::confused::confused:

kuotown 11-13-2007 06:45 PM

Yeah I am kidding about the trade it in part. That is just frustration showing through. I have no problem with mechanical issues that I can fix, but electrical issues drive me insane. I wish there was a way to swap in a working headlight switch to see if that is the problem without spending the 90 bucks to buy it first. Too bad you can't buy electrical parts and return them if they don't fix the problem!
I appreciate all the help and insight I have gotten so far. Any more ideas??? Keep them coming please! Thanks so much!!!!

c125bob 11-13-2007 08:22 PM

My 2000 TJ blinker (left) would come on solid, no blink, when I pressed the brake pedal. It did this "sometimes" and nearly drove me nutz !

Turns out it was a bad ground, in the blinker assembly, in the steering column right behind the steering wheel. Took off the shroud, unplugged the unit, swapped the new one in, and put it back together. No more problems.

I don't know what's wrong with yours, but it solved my problem. I think I paid about $90 for the part, whew ! Good luck somebody here will probably know what's wrong, it's a great site.

Sent this just FYI.
bob

1998TJ 11-13-2007 08:26 PM

Quote:

Originally Posted by c125bob (Post 158136)
My 2000 TJ blinker (left) would come on solid, no blink, when I pressed the brake pedal. It did this "sometimes" and nearly drove me nutz !bob

Thats funny mine started doing this about a week ago. mainly when it's raining.

foxinthemudd 11-13-2007 10:58 PM

when I did the flush LED tail lights on my rig thats just how they are never heard of a "blinking too fast ticket" though.

Triple88a 11-13-2007 11:11 PM

you can edit the flasher relay to ELIMINATE the too fast flasher/burnt out bulb option.

http://www.stu-offroad.com/electrical/led1/led-3.htm



before you mess around w/ the relay try that....

Mine also does it once in a while. Play around w/ the emergency blinkers switch on top of the steering column a bit. With mine if i play around w/ the switch it goes back to normal.

Joe Dirt 11-14-2007 03:10 AM

water getting in the bulb socket causes corossion that makes voltage drop. That drop causes the flasher to speed up. That little bit of info cost me $75 at the dealership. Clean up your sockets and try it.

kuotown 11-14-2007 12:22 PM

I figured out the problem. The factory bolts that bolt the tail light assembly onto the tub were rusted out along with the tub. I replaced it with larger bolts after re-tapping the holes and I eliminated the rubber spacers/washers that were on the factory bolts and it now works perfectly! Thank you to everyone for the ideas and help with this issue. It is greatly appreciated!

bgmiller 01-09-2008 09:51 PM

I have the problem with my front left side marker. It used to be an intermittent, which started 9 years ago, problem like RIPBiker13, 1998TJ and same problem as c125bob also. So are you suggesting that I check all attaching screws and replace them if they are rusty? I bet they all are rusty. I also have a problem with my blinker/high-low beam switch on the steering column. When I put on the left side nothing happens unless I put left pressure on the handle forcing it slightly to the down. I have replaced my head light switch about 5 years ago. I hope you read this and give me some input.

Ripp 07-30-2009 04:53 PM

where is the FLASHER LOCATED!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!?

Ripp 07-31-2009 12:03 AM

Never mind! I found it. It wasn't bad anyway. I replaced the fuse that is under the hood number 27 I think and then replaced the bulbs with the factory bulbs instead of installing LEDs they just blinked fast and didn't work some of the time. I'm just going to start on my Cummins turbo Diesel install. Taking the 4.0 out. Should be fun!

meyers 07-31-2009 01:03 AM

Sounds like a ground issue.

Levinoss 07-31-2009 01:15 AM

No no NO! You all got it wrong....

http://kalecoauto.com/images/BlinkFluid.jpg

Gotta make sure the blinker fluid is changed every 1,500,000 blinks.

meyers 07-31-2009 01:51 AM

Quote:

Originally Posted by Levinoss (Post 412145)
No no NO! You all got it wrong....

http://kalecoauto.com/images/BlinkFluid.jpg

Gotta make sure the blinker fluid is changed every 1,500,000 blinks.

WOW thanks man, missed that in the maintenace interval schedule. Can I do this myself or should I take it to the dealer? It is going in this week to have the tail pipe de-carbonized maybe they could do that then..

Levinoss 07-31-2009 02:14 AM

Quote:

Originally Posted by meyers (Post 412154)
WOW thanks man, missed that in the maintenace interval schedule. Can I do this myself or should I take it to the dealer? It is going in this week to have the tail pipe de-carbonized maybe they could do that then..

They will charge you a arm and a leg if you have someone do it. When you buy the fluid just order some elbow grease also and you should be set.

http://kalecoauto.com/images/elbowgrease.jpg

imowt 10-06-2009 08:42 PM

Quote:

Originally Posted by c125bob (Post 158136)
My 2000 TJ blinker (left) would come on solid, no blink, when I pressed the brake pedal. It did this "sometimes" and nearly drove me nutz !

Turns out it was a bad ground, in the blinker assembly, in the steering column right behind the steering wheel. Took off the shroud, unplugged the unit, swapped the new one in, and put it back together. No more problems.

I don't know what's wrong with yours, but it solved my problem. I think I paid about $90 for the part, whew ! Good luck somebody here will probably know what's wrong, it's a great site.

Sent this just FYI.
bob

I was thinking of replacing my blinker assembly also...
I believe it smoked and shorted out. Is it hard to replace.
Is this a dealer part?


All times are GMT -5. The time now is 02:57 AM.