Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   WF New Member Check In (http://www.wranglerforum.com/f12/)
-   -   Newbie from UK - PLZ HELP!! (http://www.wranglerforum.com/f12/newbie-from-uk-plz-help-132276.html)

Alula 01-10-2012 04:50 AM

Newbie from UK - PLZ HELP!!
 
Hi all ...

Just joined today,

Got myself a '05 Wrangler 4.0L in Oct last year and have to say, it's a brilliant car, or should I say toy.. Been offroading twice with it, and WOW, for a standard 4 wheeler, the offroad capabilities is amazing :thumb:

BUT, now for a brain teaser .. a few weeks ago, my flasher unit starts making a buzzing noise, and the indicators died.. I replaced the unit, but still now indicators or hazards.. I check fuses, bulbs etc, but no luck .. :banghead:

Any help here would be great ..

thx guys!!

blkrubi88 01-10-2012 04:53 AM

Welcome! Try posting in the TJ tech section you'll get more help to your problem, good luck.

JDsDream 01-10-2012 05:17 AM

Welcome to the Forum

Templar 01-10-2012 11:06 AM

Welcome to WF :)

Beastmaster 01-10-2012 11:27 AM

Welcome to the forum!

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)

Ageless Stranger 01-10-2012 04:57 PM

Welcome to WF. :cool:

Barrie 01-10-2012 04:58 PM

Welcome:wavey:

shell 01-10-2012 07:23 PM

Welcome!:wavey:

DarthJeep 01-10-2012 08:14 PM

Welcome to WF. Hope you find a solution to your issue. I'm sure someone will be able to help. :wavey:

98tj.steven 01-10-2012 08:15 PM

Welcome!!


All times are GMT -5. The time now is 02:51 AM.