Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Indicators and Hazards issue on TJ - Need a hand PLZ (http://www.wranglerforum.com/f282/indicators-and-hazards-issue-on-tj-need-a-hand-plz-132278.html)

Alula 01-10-2012 06:04 AM

Indicators and Hazards issue on TJ - Need a hand PLZ
 
Hi all ...

Got myself a very interesting electrical issue on my '05 Wrangler 4.0L .. a few weeks ago, my flasher unit starts making a buzzing noise, and then the indicators died.. I replaced the unit (as I thought this is the obvious issue), but still now indicators or hazards.. I check fuses, bulbs etc, but no luck .. :banghead:

Any help here would be great ..

thx guys!!

mrobinso 01-10-2012 09:51 AM

This topic is covered to death on the forum, just use the search. I am actually going through a similar problem right now myself. If you are saying you replaced the turn signal switch, you probably forgot to replace the flasher/signal relay while you were doing it. Make sure you replaced the relay (in the '05 it the relay should be included as part of the turn signal housing you removed if you replaced the switch). My '99 has the relay on the right hand lower side of the front panel near where your right knee points while seated in the driver's seat.

Alula 01-10-2012 10:33 AM

I did replace the Flasher Unit / Relay and not the turn signal switch .. On mine, the unit/relay sits right ontop of the steering column

I'll search the forum to these topics, and hopefully get it fixed, before forking out hard-earned cash to get it sorted, as I'm sure it will be something small / easy to fix ... or let me rather say --- I Hope..

mrobinso 01-10-2012 10:58 AM

Where did you buy your relay - I had a hard time finding it except online? Replacing the turn signal switch could be a possible solution - but not necessarily the right one for solving your problem. I have a used turn signal from my TJ that I took out and replaced with a new one, only to find the switch wasn't the problem and the old one was working fine. Will sell it to you for $25 shipped (costs about $40 for a Chinese knock off on eBay).

Alula 01-10-2012 11:38 AM

Quote:

Originally Posted by mrobinso (Post 1906870)
Where did you buy your relay - I had a hard time finding it except online? Replacing the turn signal switch could be a possible solution - but not necessarily the right one for solving your problem. I have a used turn signal from my TJ that I took out and replaced with a new one, only to find the switch wasn't the problem and the old one was working fine. Will sell it to you for $25 shipped (costs about $40 for a Chinese knock off on eBay).

Would be happy to pay $25 shipped, I'm in the UK .. offer still stands?? :whistling:

The only place I could find a flasher relay this side of the pond, was at a breakers yard (for the bargain of 35 (avg $50) - have I mention it's second hand), they did test it and ensured me it's working.. but yes, that little nagging thought is in the back of my head .. is it really working.....:confused:

o Walla 03-01-2014 04:41 PM

try a new multi function switch. they are common to go bad and its like 25 30 bucks. that fixed my issue when i had that problem. if that doesn't work then it could be the clock spring wich you need to take the steering wheel off for. and i hear they are expensive.


All times are GMT -5. The time now is 09:09 AM.