Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   headlight problem when cold (http://www.wranglerforum.com/f282/headlight-problem-when-cold-133629.html)

lucky4075 01-16-2012 10:24 PM

headlight problem when cold
 
Hey all,

I have a weird problem with my headlights when its cold outside during the winter. When I pull the lights switch to 'ON' they wont come on right away, usually it takes a few minutes of driving before they switch on. I tried flicking the high beams on but they wouldnt come on either. It only does this when its cold out too, during the summer/ warmer months they switch right on. Any thoughts? Bad switch, bad relay? 97 sport.

LilYeller 01-16-2012 10:33 PM

If it were me I would test voltage at the lights. See if power is getting to them. If it is getting power then the problem is the lights. if not then test voltage at the switch, then at the relay. Eventually you will find the source of the issue. Sounds more like a switch problem than anything else to me, but who knows.

DevilDogDoc 01-17-2012 12:03 AM

It's the switch. Mine did the same thing before it died completely. $20 for the switch, 20 minutes and done.

dougncrew 01-27-2012 05:07 PM

Mine did the same thing but I was to lazy to go to the stope for a switch. I just took a relay that I had tapped into the parking lights and wired to the low beam. I should replace the switch some day so i have high beams again.


All times are GMT -5. The time now is 03:28 AM.