Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   WF New Member Check In (http://www.wranglerforum.com/f12/)
-   -   Help 95 Jeep Wrangler Grand Rio 4X4 (http://www.wranglerforum.com/f12/help-95-jeep-wrangler-grand-rio-4x4-135755.html)

nboyer71 01-26-2012 11:05 PM

Help 95 Jeep Wrangler Grand Rio 4X4
 
Ok First I would like to thank anyone who responds or comments cause I am at a dead end with my jeep !

Problem It startes about 2 months ago I was going down a interstate about 60 65 MPH and all of the sudden the Jeep just cut off still rolling going 65 MPH everything stayed on except obviously the engine and also I thought that the Speed sensor Unit would still register with the key in the on position while it cut off but the speedometer was not registering long long story short now all it does is sometimes RANDOMLY cuts off you can go 60 miles one day work fine next day go 2 and it would cut off

I can Go outside start it up right now and go a couple of miles and it cut off and be stranded

I have replaced Gas, Fuel Filter( which was dirty) Cap and Rotor ( which seemed to help a little bit) the Fuel Pressure Regulator Vaccum line which was dry rotted and cracked which i thought logically speaking if theres no suction that would be why it is cutting off all of the sudden because of the regulator not opening and cause no fuel to the Fuel Rail the only thing i have not done is Clean/Replace Fuel Injectors I dont want to spend 250 $ on Injectors and it not fix it even though it wouldnt hurt them checked all Wires and plugs all are fine all grounds to chassis and motor are not corroded with acid or anything ! the only thing i could think of was its either an Electrical/Eletronic problem or Fuel Injectors ???


Any help as I said Would be greatly appreciated by me and my wife!!

kbwwolf 01-26-2012 11:38 PM

Post this in the YJ forum...you'll get answers there. Just cut n paste into a whole new thread.

And welcome to WF! :thumb:

nboyer71 01-27-2012 12:16 AM

Oh did I post it in the wrong place im sorry as you can see I am New Thank you

Templar 01-27-2012 03:33 AM

Good Luck with the issue, Welcome to WF :)

blkrubi88 01-27-2012 03:51 AM

Welcome!

JDsDream 01-27-2012 06:17 AM

Welcome to the Forum

You did not post in the wrong place, it's just not the best place to get answers to mechanical questions. We are here to help and sometimes (often) it is just a matter of getting our newcomers to the best place to find those answers.

Beastmaster 01-27-2012 09:20 AM

Welcome to the forum!

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)


All times are GMT -5. The time now is 05:11 AM.