Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Wiring a 1997 Hardtop to a 2006 TJ? (http://www.wranglerforum.com/f210/wiring-a-1997-hardtop-to-a-2006-tj-13712.html)

halfbaked 12-03-2007 12:49 PM

Wiring a 1997 Hardtop to a 2006 TJ?
 
I am attempting to connect the rear wiper motor wiring for a 1997 hardtop to a 2006 harness which is wired to my 2006 TJ. The connectors do not match. Any information on the connections would be greatly appreciated. In particular how should I connect the three wires from the wiper motor (12V, Ground, and ???).

I found one pin in the 2006 harness connector (jeep side) that responds to the wiper switch. With the switch in the on postion it provides a ground. I also found one pin the harness that provides a constant 12V when the ignition is on. The wiper motor has three wires. If I connect one of them to constant 12V and the other to the switched ground, I am able to control the wiper via the switch but the wiper does not return to its starting position properly when turned off. I assume that the third wire is required for this to work.

parrot head 12-03-2007 02:24 PM

Yes that third wire is for the "park" function on the wiper motor. If your switch operates by supplying a ground source and you already have a constant 12v supply, I would think that the third wire would be a constant ground. Then you would have constant power to the wiper motor for the "park"function. This only powers the motor if the wiper is not in the "home" position and automatically stops the motor when it is.

halfbaked 12-04-2007 06:33 PM

If I connect the third wire to one of the constant ground pins, I blow the fuse. If I connect the third wire to the constant 12V the "park" function appears to work but I have no 12V pin to drive the motor. The pins in the jeep side connector are as follows:

pin 1: constant ground
pin 2: constant 12V when ignition on
pin 3: ??? No voltage or continuity with other pins or ground
pin 4: 12V when defrost switch is on
pin 5: ground when wiper switch is on

Interestingly enough the color coding of the harness wires connected to pins 2 and 3 are the same. When I connect the wiper motor wires to these two pins, only pin 2 provides power. Hmmm.

parrot head 12-05-2007 12:21 PM

How about splitting the constant 12v and feeding the park function as well as the regular wiper function.

parrot head 12-06-2007 08:57 AM

I found my 1997 service manual. It has a wiring diagram for the rear wiper motor. It shows the black wire going to a constant ground. The light green goes to +12v switched. The brown/pink goes to +12v constant. Hopefully this makes some sense.


All times are GMT -5. The time now is 10:52 AM.