Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   speedometer issue (http://www.wranglerforum.com/f274/speedometer-issue-137939.html)

davenfg182 02-06-2012 04:15 PM

speedometer issue
 
i put in white gauges and in the process i must of slightly bumped the speedometer needle and now when i shut my car off it dips down below the zero and i must manually move it up to the 0 before i drive. it works perfectly fine, accurate speed but just want stay stuck at the zero. please help!

kbwwolf 02-06-2012 05:06 PM

Quote:

Originally Posted by davenfg182 (Post 2000628)
i put in white gauges and in the process i must of slightly bumped the speedometer needle and now when i shut my car off it dips down below the zero and i must manually move it up to the 0 before i drive. it works perfectly fine, accurate speed but just want stay stuck at the zero. please help!

First I've heard of that one. Thread below may help, though it's not for a Jeep. Sounds almost exactly like your problem, though:

Speedometer won't stay calibrated - Puget Sound MINI Motoring Club Forums

Good luck! :thumb:

RB-10rubicon 02-23-2012 06:31 PM

How do you like your white gauges ?was thinking about getting them..do you have a pic?

davenfg182 02-27-2012 04:38 PM

Quote:

Originally Posted by RB-10rubicon (Post 2067149)
How do you like your white gauges ?was thinking about getting them..do you have a pic?

well if i could get the speedometer issue i'm sure i would like them. havent put them on but from the other pics i seen they look pretty cool.

RB-10rubicon 03-08-2012 09:41 PM

Did my gauges today ..ill take pics tommorow .was real easy .i like the daytime look not sure about night time look .but im sure it will grow on me


All times are GMT -5. The time now is 01:50 PM.