Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Starting my Jeep...little rough (http://www.wranglerforum.com/f282/starting-my-jeep-little-rough-139562.html)

SemajNosneb 02-13-2012 10:32 PM

Starting my Jeep...little rough
 
So I have a 06 TJ unlimited 4.0, and I have been really involved in the routine maintenance lately, as Im just starting to really understand my Jeep, and taking care of it. I had starting issues with my Jeep about 3-4 months ago, I tested my battery before and after charging, and running, and determined that it was time to replace. So I replaced the battery and everything was good till about 2 weeks ago. I havn't ran into a situation where it didn't start, but its been starting slow. Taking a little too long to kick over. Now I do live in chicago so its cold as hell, but sometimes I try and it wont kick over after 5-7 seconds, I wait 10 seconds, try again and it goes. So.... Starter? Do you think cleaning my terminals for the starter will do the trick? Rebuild the starter? Buy a new one? Thanks

SemajNosneb 02-13-2012 10:44 PM

Could it be the alternator?

jerladd 02-14-2012 07:31 AM

Have you put a voltmeter on the alternator while it's running to see if it's putting out a sufficient charge? When you crank it does it the starter turn the engine over pretty fast or does it start fast and slow down? If your engine is turning over it doesn't sound like your starter. A bad starter will usually make a grinding or clicking sound. I'd look into Seafoam too, it's a great product and you can use it to clean your injectors and everything. Hope that helps.


All times are GMT -5. The time now is 07:28 PM.