Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Trying to track down an oil leak (http://www.wranglerforum.com/f282/trying-to-track-down-an-oil-leak-140837.html)

Wordgie 02-19-2012 07:53 PM

Trying to track down an oil leak
 
Here's what I got.

'99 TJ, 4.0, A/T. Not a daily driver and sits for days and weeks at a time.

Slow drip of oil into the skid plate which eventually falls to the floor. Maybe a quarter size pool per week on the floor. I just can't seem to trace the source.

I was thinking rear main seal, but it seems like it doesn't line up with the skid. I was also thinking spilled oil after an oil change since it looks like fresh oil but a month after the oil change, it's still dripping.

Any other ideas?

DMH2021 02-19-2012 08:04 PM

As a last resort, you can by oil dye at the parts store. It's not cheap. You add a quart to your oil and run the motor. Next, you get under with a black light. The dye in the oil will be glowing. We used it on a friends Mustang. That's how he found out it was his rear main seal on a new motor. Yeah....it's a Ford.

hardcoretj 02-19-2012 08:10 PM

4.0s are notorious for the valve covers leaking down the back side of the motor. I would say that small of a leak is kind of the norm.

Knowledge97 02-19-2012 08:44 PM

I have been dealing with three leaks on my 97 4.0. My rear main has a really slow leak and I am waiting a while before I replace it. I also found that the back of my valve cover was leaking so I replaced it a few weeks ago. But I still had a leak coming from somewhere on the passenger side of the block. After troubleshooting for a while I found out the oil was coming from the oil pressure sending unit. It is located right next to the oil filter. It is mostly plastic with a metal tip that goes into the block. Go for a drive a check and see if the oil is coming from there.

Wordgie 02-20-2012 12:48 PM

Quote:

Originally Posted by Knowledge97 (Post 2051044)
I have been dealing with three leaks on my 97 4.0. My rear main has a really slow leak and I am waiting a while before I replace it. I also found that the back of my valve cover was leaking so I replaced it a few weeks ago. But I still had a leak coming from somewhere on the passenger side of the block. After troubleshooting for a while I found out the oil was coming from the oil pressure sending unit. It is located right next to the oil filter. It is mostly plastic with a metal tip that goes into the block. Go for a drive a check and see if the oil is coming from there.

Were any of those leaks accumulating in the skid plate?

I'm really leading toward the valve cover as it seems like the oil isn't constantly leaking like it would with the RMS.

Owen_TJ 02-20-2012 12:55 PM

Valve cover gasket or the Rms...one of the two

Knowledge97 02-20-2012 03:25 PM

Quote:

Originally Posted by Wordgie (Post 2052960)
Were any of those leaks accumulating in the skid plate?

I'm really leading toward the valve cover as it seems like the oil isn't constantly leaking like it would with the RMS.

Yeah my RMS is dripping to the center of my skid plate, and the oil pressure unit was dripping to the passenger side of my skid plate.

Wordgie 03-24-2012 01:44 PM

Finally got a chance to crawl under the Jeep today. There's a LARGE accumulation of oil on the top side of the trans and signs of flowage down the sides which coincides with the puddle in the skid plate.

I could also see a pretty good stain on the rear driver side of the block at the valve cover but it doesn't look like it flows too far down.

What I also found was a rubber tube type thing on the rear driver side of the trans. Looks like it goes to the rear for a short distance then straight up. There are wire strands coming out of it and I'm not sure if it's electrical wires or wire strands from the tube. I'm thinking either a supply line but its not leaking that bad or a sending unit/sensor but I'm not getting a warning.

shadews 03-24-2012 03:19 PM

I have a RMS leak and an Oil pan gasket leaks on my 04 rubicon with 78k. Im not the original owner so I am not sure how that person treated it. My front locker is having issues as well....ugh. Im going to replace the oil pan gasket myself and then just leave the RMS alone. My RMS didnt start leaking until I changed to synthetic oil on my last change. I heard that was pretty common. Its maybe a quarter sized every week as well.

Are you using synthetic oil? If you change back to conventional then it might stop. Thats another thing I was told at least.

Wordgie 03-24-2012 08:57 PM

Here's a pic of the part.

Directly above the rear edge of the tranmiion pan. Black line/cable almost look like a coax cable, bent at a 45 degree angle up. The accumulated oil is on the horizontal surface directly above this piece.

http://i262.photobucket.com/albums/i...d/80f0c770.jpg

Wordgie 04-24-2012 04:55 PM

Got the leak tracked down. in the process of removing the valve cover I broke the CCV elbow. When I researched that replacement I discovered it's also a culprit of oil leaks.

Based on the oil film on the valve cover I'd have to say that was my issue. Oh well, gonna have a new gasket AND CCV elbow/grommet.

birdmann 05-22-2012 08:59 PM

I have a 2004 LJ with a small oil leak, I was going to change the V/C gasket. But there is a plastic clip on the v/c on the drivers side near the fire wall holding an elictrical wire loom. How do you get that off without breaking it?

migbuz 05-22-2012 10:09 PM

I don't know if there's a better way or a proper way but I used a screwdriver to pry it off


All times are GMT -5. The time now is 12:23 AM.