Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Rough Idle help (http://www.wranglerforum.com/f282/rough-idle-help-140930.html)

bal31 02-20-2012 10:22 AM

Rough Idle help
 
I have a 2002 TJ with a 4.0....IT has a little bit of a rough idle. Nothing bad, but just slightly rough. IT has 70,000 miles on it. I took the Throttle body off and cleaned it the TPS and the IAC. I also changed the plugs and put seafoam in the gas. I still have a rough idle. Any other ideas of things i can do??

mudmagnet63 02-20-2012 11:30 AM

Plug wires? an easy way to check raise the hood at nite and look for sparking. Much better than gettin bit. or bad gas

kfdjason7620 02-20-2012 11:33 AM

2000 and newer have no plug wires

mudmagnet63 02-20-2012 11:59 AM

Quote:

Originally Posted by kfdjason7620 (Post 2052722)
2000 and newer have no plug wires

Learn something new everyday. Coil Packs I guess?

kfdjason7620 02-20-2012 12:16 PM

That's right, well actually they switched over at mid year 1999

bal31 02-20-2012 12:29 PM

I was thinking possibly and O2 sensor???

kfdjason7620 02-20-2012 12:47 PM

Had bad gas mileage?

bal31 02-20-2012 02:04 PM

Nope...getting between 18-20 mpg... I have had a few emissions codes( P0442, P0455, P0456). Checked all of the EVAP lines and fuel lines. Can't find any leaks. Replaced gas cap. it is odd to me that my gas mileage is still really good.

bal31 02-21-2012 06:57 AM

Bump...

wwch99tj 02-21-2012 07:02 AM

You said you were thinking 02 sensor try unplugging it and see if it runs any better, when you unplug it it will run off of the computer presets. Does it idle rough all the time when its cold and warmed up

AVtj03 02-21-2012 07:27 AM

Quote:

Originally Posted by wwch99tj (Post 2056456)
You said you were thinking 02 sensor try unplugging it and see if it runs any better, when you unplug it it will run off of the computer presets. Does it idle rough all the time when its cold and warmed up

won't it run worse if you do that?

o2 sensor is part of regular maintenance that commonly gets overlooked (me too). I think they should be changed out ever 75k to 100k. I have 117k on mine, and its hasn't been changed.

I had a pretty rough idle and it ended up being my #5 plug. After I changed my plugs, it obviously ran a lot better.

It really depends on you and how rough your idle is. It wouldn't hurt to check your coil packs and possibly change out the o2 sensor. Good Luck!

wwch99tj 02-21-2012 07:31 AM

Quote:

Originally Posted by AVtj03

won't it run worse if you do that?

No it won't run worse if you unplug it. It runs worse with it plugged in feeding the computer the wrong information.

AVtj03 02-22-2012 07:12 AM

Quote:

Originally Posted by wwch99tj (Post 2056538)
No it won't run worse if you unplug it. It runs worse with it plugged in feeding the computer the wrong information.

ya, guess ur right.


All times are GMT -5. The time now is 01:18 AM.