Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Engine Briefly Dies on Hwy. (http://www.wranglerforum.com/f282/engine-briefly-dies-on-hwy-140990.html)

crallscars 02-20-2012 02:11 PM

Engine Briefly Dies on Hwy.
 
I was coming back from Miami over the weekend, while driving 75 the engine cut out a couple times. No engine lights, 1/2 tank of gas I slowed down pulled into a rest area, under the hood looked as ok as you can tell without test equipment. I noticed if I drove slower, that I didn't have the engine cutting out. When I drove faster it would start cuttung out again.

I got back on the road, 120 miles from home thinking "The Closer I Get, The Shorter The Tow"

I was thinking maybe my fuel pump with 215,000 miles on it was dying so I filled the tank and kept it full till I got home.

Time for a fuel pump?

KrzyMoke 02-20-2012 02:33 PM

Mine did that with no codes as well. Eventually it was the TPS. Be sure to buy the Factory one. It comes with new hardware that is worth their weight in gold.

BladeMechanical 02-20-2012 03:36 PM

What was the cost of the TPS?

cadenas 02-20-2012 03:40 PM

It was around $45 for my tj from auto zone. If you get it from the dealership its around $120

jcmstrickers 02-20-2012 03:41 PM

Advance auto parts for 42 bucks with lifetime warranty

crallscars 02-20-2012 03:57 PM

Whats a "TPS" ? is that the engine computer module?

eagle223 02-20-2012 03:59 PM

Quote:

Originally Posted by crallscars
Whats a "TPS" ? is that the engine computer module?

Throttle position sensor

crallscars 02-20-2012 04:23 PM

Good thought, I have had them go on my Dodge/Cumins.

I guess you can check them with an ohm meter to see if the pot is noisy.

KrzyMoke 02-21-2012 04:46 PM

Quote:

Originally Posted by BladeMechanical (Post 2053593)
What was the cost of the TPS?

I spent more than normal, I went to the dealer. I think 68. But I wanted the hardware too. I read on here (Yes I actually used the search tool :) and they said to buy the factory one. It is hit or miss on Auto Parts stores quality.

KrzyMoke 02-21-2012 04:47 PM

Quote:

Originally Posted by cadenas (Post 2053611)
It was around $45 for my tj from auto zone. If you get it from the dealership its around $120

WOW mine was way cheaper. But I'm in Texas :)

C.L. 02-21-2012 05:06 PM

I got one off rockauto that seems to be holding up just fine. Mine threw codes before it went though, and generally they have more issues at idle or while changing speed.

Since you said you had more issues at higher speed, i would lean towards a fuel starve condition. Either dying pump or clogged filter. It would be able to deliver enough fuel to keep the Jeep running at idle and lower speeds, but not keep up at high speeds.

Maybe pressure check it while revving the engine to see if it drops significantly?

jcmstrickers 02-21-2012 07:48 PM

I don't know if you have installed it our not but when you do disconnect the battery afterwords to reset the computer.

crallscars 02-22-2012 08:01 AM

I do appreciate all the replies.

When it stalled out, I didn't get an engine light, so I haven't looked to see if there are any codes. I just figured it was a pump failing and couldn't deliver enought fule to drive 75mph.

I had a half tank of gas, so I topped it off and the problem seemed to go away? Again my thinking is cooler fuel pump, maybe easier to draw from a full tank?

I'll check the pressure tonight. What should it be? 40ish?

crallscars 02-23-2012 09:58 AM

I just spoke to my Jeep /Chrysler dealer, the price for a TPS is $120 with a discount. He didn't think it would fix my problem either, he was thinking more along the 'Distributor Plate' or computer as the problem.

I would think either would give me an engine light....your thoughts?

Time to change the fuel pump?

Zinger 02-23-2012 10:12 AM

I'll second the Distributor Ignition Pickup - I've had it with a past (Chrylser) vehicle, running fine and engine just dies. Coast to the side and restart and seems fine. When it happens it's like a light switch - On then Off.

Jowilly 02-23-2012 10:19 AM

Any chance it could be something as simple as a partially plugged fuel filter?

Zinger 02-23-2012 11:43 AM

A fuel delivery problem (pump, regulator, filter) usually display themselves with a degrade or progressive loss in power. An abrupt loss (and restore) of power leads me to believe ignition issue. The ignition pickup is an item that can easily be changed (5 min) for a reasonable cost ($25). I'm willing to bet crallscars has a 5 speed and the engine refires being it's "hooked-up". With my previous vehicle it was and automatic would JUST DIE and I would have to use the key to restart. It also became more of a problem (more frequent) with higher (under hood) temps.

crallscars 02-23-2012 12:24 PM

Thanks for the replies. Yes it's a 5 speed, and when it failed it was a brief on off on, and did it a few times in a row. I reduced speed and noticed it only if I increased speed. I topped off the tank and didin't notice it again, although I kept my speed down.

Wouldn't an ignition problem turn on the service engine light?

The plate does sound like a cheep guess.

Zinger 02-23-2012 02:01 PM

It won't give a code it just provides an signal for the engine rotation (crank position.) How did you tach behave? I believe it provides the signal for that too.

Zinger 02-23-2012 02:24 PM

Let me revise that statement - it won't put up a code but, it can be seen by a scan tool if it has TOTALLY failed. Then your engine will crank fine - but you'll have no spark and won't run. The computer doesn't see a fault because it doesn't know the engine is going around. It records things out of spec (codes) only when the engine is running. Being it doesn't see the rotation it doesn't see a fault.

crallscars 02-23-2012 02:45 PM

Zinger, your thoughts on it being a strong possibulity?
I wasn't looking at the tach, I will next time.

Zinger 02-23-2012 02:55 PM

If it shut off and came back on - just like flipping a switch - REAL ADBRUPT - Then yes, replace it. I fought with my vehicle for a couple of months before I was directed to replace it (by the parts manager at the dealer desk.) No real pattern - some days fine others it would show up - then go away again. Replaced it and cured.

crallscars 02-23-2012 03:10 PM

Zinger,
Thanks for the assistance, I have one on order with the local Chrysler/Dodge/Jeep dealer.

Zinger 02-23-2012 05:12 PM

Good Luck - I hope that's it. It's a simple fix.


All times are GMT -5. The time now is 12:24 AM.