Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   1 out of 3 brake lights (http://www.wranglerforum.com/f218/1-out-of-3-brake-lights-145089.html)

konajeep 03-08-2012 05:26 PM

1 out of 3 brake lights
 
95 YJ I had all 3 brake lights working,[tail lights work] then drivers side went out. I checked and cleaned bulb and socket put it back and both sides quit. The only brake light working is the one over the spare tire. Tail lights still work. Any ideas?

Garyk 03-08-2012 05:28 PM

You've probably got a loose or bad ground. If the light worked before you had it apart, then I would look at connections etc for corrosion...

konajeep 03-08-2012 06:31 PM

middle light
 
Why do i have the middle light working? Any ideas where to look for bad ground

Master4th 03-08-2012 07:57 PM

The Tail Lights are ground through the housing to the body. There are 3 bolts that hold your tail lights on. Those are the grounding bolts as well.

Maybe your brake switch is bad, its connected to the brake pedal. Play with it and see if you get any flickers.

Dutch 95 03-08-2012 11:51 PM

Quote:

Originally Posted by Master4th (Post 2119080)
The Tail Lights are ground through the housing to the body. There are 3 bolts that hold your tail lights on. Those are the grounding bolts as well.

If you are positive that the bulbs are not blown, I will second that^^^^^. Those mounting bolts are the ground for the lights and have to be clean!

You could also check/clean the connections in the wiring harness leading to the tail lights in each corner (looking up into each back corner from the underside). Disconnect, clean, add dielectric grease.

Because the center tail light works, I would doubt the break switch is the issue.

konajeep 03-11-2012 03:33 PM

Thanks it was the wiring plug under the dash. Corrosion


All times are GMT -5. The time now is 01:32 AM.