Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   need a little help with fuse and relay box (http://www.wranglerforum.com/f218/need-a-little-help-with-fuse-and-relay-box-145322.html)

Gkrynick22 03-09-2012 07:08 PM

need a little help with fuse and relay box
 
1 Attachment(s)
The fuse panel has 2 fuses that were replaced with wires (brilliant idea by the p.o). It is the first and seventh fuse. My questions are, what are these fuses for, what size (amp) fuse should they be, and are there any other missing fuses or relays that you notice? My jeep is a 1995, 5 speed,4 cyl, no A/C, with a factory hard top. Thanks in advance for any help.

Attachment 103514

Dutch 95 03-10-2012 12:59 AM

Both of the missing fuses replaced with wire are supposed to be 30A. All of the others are the correct value. The relays look correct; the only one missing is the A/C relay (for obvious reason). In the picture, I can't see the smaller fuses in the top left to tell if there are any missing. It looks like you only have two of the eight, but I'm not sure yet what the six missing ones are for yet. I'll do a little research and try to give you an idea of what you might check. Is there a lid over your fuse box under the hood? It should have a picture of what the fuses are printed on the inside of it. If you don't have the lid to the box, I can get you a picture of mine so you have it for reference, but I would get one in the meantime to keep water out.

Gkrynick22 03-10-2012 09:59 AM

Thanks Dutch! I assume one if the missing 30amp fuses is for the fuel pump. I found the 3 wires behind the rear driver tire were damaged and probably shorting out. I do not have the cover for the fuse box yet, so a picture would be great.

NAVYCHIEF 03-10-2012 12:23 PM

pics
 
2 Attachment(s)
i think you are missing 2 or 3

Gkrynick22 03-10-2012 07:12 PM

Quote:

Originally Posted by NAVYCHIEF
i think you are missing 2 or 3

Thanks for the pics NAVYCHIEF, does yours have A/C? Mine doesn't, which might account for the missing fuse.

Dutch 95 03-10-2012 11:20 PM

Looking at his fuse box, he has (ABS) Anti-lock breaking system, which accounts for all three missing fuses. Does yours I'm guessing your Jeep doesn't have anti-lock breaks.

Gkrynick22 03-11-2012 03:38 PM

I am pretty sure it doesn't have ABS. I found the short in the fuel pump circuit. The other jumper is supposed to be the headlights. Can't wait to have to chase that short. Lots of bugs to chase out of this Jeep. I am in the middle of changing out the fuel pump and the middle bolt in the back of the skid plate is shot. I can't fit my cutting tool between the skid plate and rear end. I am going to pick up metal saw blades for my sawsall. It will come off one way or another... Oh yeah. As I am killing myself trying to drop the skid plate I notice brake fluid pissing out of the driver side brake line. Guess I'll add brake lines to my to do list....


All times are GMT -5. The time now is 03:05 PM.