Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Jeep Hesitates when accelerating (http://www.wranglerforum.com/f274/jeep-hesitates-when-accelerating-147134.html)

jibber 03-18-2012 01:09 PM

Jeep Hesitates when accelerating
 
I have a 2009 Jeep Wrangler Sahara, 3.8L 6-Speed, and something weird started happening. When I accelerate and hit about 3,000 RPMs in any gear my jeep starts hesiatting bad and losing power. I have to let off the gas for it to stop and let the rpms get lower. Any ideas what this could be???

kjeeper10 03-18-2012 01:11 PM

Quote:

Originally Posted by jibber
I have a 2009 Jeep Wrangler Sahara, 3.8L 6-Speed, and something weird started happening. When I accelerate and hit about 3,000 RPMs in any gear my jeep starts hesiatting bad and losing power. I have to let off the gas for it to stop and let the rpms get lower. Any ideas what this could be???

How many miles?

Any lights show on the dash?

jibber 03-18-2012 01:15 PM

Quote:

Originally Posted by kjeeper10 (Post 2153113)
How many miles?

Any lights show on the dash?


It has 36000 miles. I see no lights on dash on.

JIMBOX 03-18-2012 01:17 PM

:whistling: Does the Elex Throtle Control (ETC) RED LIGHTNING icon lightup ??

It's item #30 in your owners manual Dashboard icon chapter and tells about various sensors to control your throttle !

:dance::rofl: JIMBO

cf1 03-18-2012 01:20 PM

Quote:

Originally Posted by JIMBOX (Post 2153130)
:whistling: Does the Elex Throtle Control (ETC) RED LIGHTNING icon lightup ??

It's item #30 in your owners manual Dashboard icon chapter and tells about various sensors to control your throttle !

:dance::rofl: JIMBO

try a diffrent brand of gas , mine did the same thing untill i changed brands of gas.

kjeeper10 03-18-2012 01:25 PM

Quote:

Originally Posted by JIMBOX
:whistling: Does the Elex Throtle Control (ETC) RED LIGHTNING icon lightup ??

It's item #30 in your owners manual Dashboard icon chapter and tells about various sensors to control your throttle !

:dance::rofl: JIMBO

That's what I was thinking.

No "flashes" the ETC light will not stay on I don't think. Just flash.

I dont think bad gas will be RPM specific??

Sounds like a sensor problem or possibly a misfire/engine knock causing the knock sensor to cut throttle :confused:

jibber 03-18-2012 01:33 PM

UPDATE!! I just drove my jeep again and am completely losing power. It will idle fine, but if I am sitting still and give it gas, the RPMs will go up and then hhesitate and go back down. Even if I am still holding the gas pedal down. Can hear an occasional backfire too. This is frustrating. I can't even drive it to the dealer to have them look at it. I just bought this thing 2 weeks ago!

kjeeper10 03-18-2012 01:34 PM

Quote:

Originally Posted by jibber
UPDATE!! I just drove my jeep again and am completely losing power. It will idle fine, but if I am sitting still and give it gas, the RPMs will go up and then hhesitate and go back down. Even if I am still holding the gas pedal down. Can hear an occasional backfire too. This is frustrating. I can't even drive it to the dealer to have them look at it. I just bought this thing 2 weeks ago!

Check your wires/plugs

jibber 03-18-2012 01:43 PM

And the ETC light is NOT on and is NOT flashing.

JIMBOX 03-18-2012 01:51 PM

:whistling: If it's an auto--there's a little gold engine profile icon just under thr "P", when it lights up it shows OBD11 engine trouble and should exibit a failure code--

Otherwise it could also be gas filter contamination and there's nothing you can do aboutit--dealer time-

Good luck

--JIMBO

jibber 03-18-2012 01:55 PM

It is a 3.8L, 6-speed MANUAL transmission. And there are NO dash lights on. NONE.

jibber 03-18-2012 02:20 PM

The engine seemed really hot when I opened the hood initially but the temperature guage was in the middle between Hot and Cold. I just let it set for about 20 minutes and it ran ok for a few seconds and then went back to the same thing.

pkmcd99 03-18-2012 02:20 PM

Quote:

Originally Posted by jibber
UPDATE!! I just drove my jeep again and am completely losing power. It will idle fine, but if I am sitting still and give it gas, the RPMs will go up and then hhesitate and go back down. Even if I am still holding the gas pedal down. Can hear an occasional backfire too. This is frustrating. I can't even drive it to the dealer to have them look at it. I just bought this thing 2 weeks ago!

MAP SENSOR, test the resistance with a meter. They can fail and not trip a code.

JIMBOX 03-18-2012 02:27 PM

:whistling: Here's a simple free check--

Open your airfilter box and remove the filter---HOW DOIT LOOK ??

Vacuum the box all around and without putting the filter back in--startit and see how the engine ops--DON'T DRIVE LIKE THAT, BUT it may tell you something !

:dance::rofl: JIMBO

jibber 03-18-2012 02:32 PM

Quote:

Originally Posted by JIMBOX (Post 2153271)
:whistling: Here's a simple free check--

Open your airfilter box and remove the filter---HOW DOIT LOOK ??

Vacuum the box all around and without putting the filter back in--startit and see how the engine ops--DON'T DRIVE LIKE THAT, BUT it may tell you something !

:dance::rofl: JIMBO


It has a K&N filter on it

Celtic 03-18-2012 02:34 PM

Been in the water lately?

kjeeper10 03-18-2012 02:36 PM

Quote:

Originally Posted by pkmcd99

MAP SENSOR, test the resistance with a meter. They can fail and not trip a code.

Yep check the map

Probably loaded with oil from the K&N :whistling:

JIMBOX 03-18-2012 02:36 PM

:whistling: Thats too bad--there could be the problem, with contaminated MAP SENSOR, from using the K&N filter--like pkmc mentioned !


Quote:

Originally Posted by jibber (Post 2153276)
It has a K&N filter on it

-JIMBO

jibber 03-18-2012 02:39 PM

Where is that located?

kjeeper10 03-18-2012 02:44 PM

Bingo :thumb:

JIMBOX 03-18-2012 02:46 PM

:whistling: google "Jeep JK MAP Sensor" and then what are you going to do ??

Get some onsite help--

--JIMBO

SilverSport 03-18-2012 03:20 PM

Similar symptoms to plugged cat.

jibber 03-18-2012 03:26 PM

I found my MAP sensor, took it off and did not look like there was oil in it. I blew it out with my air compressor, installed it and same symptoms. I gave up, had my wife follow me to the dealership and dropped it off. I had the jeep for two weeks and put less than 200 miles on it. It is THEIR problem now. It is under warranty.

kjeeper10 03-18-2012 03:31 PM

Quote:

Originally Posted by jibber
I found my MAP sensor, took it off and did not look like there was oil in it. I blew it out with my air compressor, installed it and same symptoms. I gave up, had my wife follow me to the dealership and dropped it off. I had the jeep for two weeks and put less than 200 miles on it. It is THEIR problem now. It is under warranty.

Well that's good. Hopefully they figure it out.

JIMBOX 03-18-2012 03:32 PM

:whistling: Sounds good--they'll fixit--please post the findings , so we'll all know what it was--

Good luck-

:dance::rofl: JIMBO

jibber 03-18-2012 03:33 PM

Quote:

Originally Posted by JIMBOX (Post 2153391)
:whistling: Sounds good--they'll fixit--please post the findings , so we'll all know what it was--

Good luck-

:dance::rofl: JIMBO


I definitely will. Thanks for everyone's help!

ESP 03-18-2012 04:31 PM

Subscribed.

jibber 03-18-2012 05:54 PM

Quote:

Originally Posted by Celtic (Post 2153280)
Been in the water lately?


And no, NO water.

jibber 03-19-2012 01:46 PM

UPDATE!! Well, I got a call from the Master Technician and they ran some tests and determined that there is a problem with the fuel pressure and they believe it is the fuel pump. They ordered a fuel pump (will be there tomorrow) and will have to drop the tank to install it. They said they will inspect the tank and everything else while the tank is dropped to eliminate any other possible problems. SO, I should know by the end of the day tomorrow if the fuel pump was the problem. Either way, I am getting a new fuel pump at their expense.

Celtic 03-19-2012 01:50 PM

Good luck, keep us posted.


All times are GMT -5. The time now is 01:17 PM.