Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Jeep does some hesitation while cold (http://www.wranglerforum.com/f282/jeep-does-some-hesitation-while-cold-147179.html)

Gorving3 03-18-2012 05:15 PM

Jeep does some hesitation while cold
 
After a cold start up (anywhere from 20-60 degrees) there will be a couple of slight hesitations during acceleration the first block or two. If it were a carburetered engine I'd think either the accelerator pump was bad or the choke was hanging open but being a 2001 4.0 engine that can't be the case. Installed new Autolight APP plugs about 2,000 miles ago.
After a couple miles warm up everything runs smooth as silk.
Any suggestions as to what might be going on? I've tried to avoid any 10% ethanol gas but sometimes forget and have also noticed some stations will have it posted on one pump but not the other. Should ask why but most clerks don't know what's put in the tanks.

Kevinw23 03-18-2012 06:36 PM

No expert here, but I had a similar problem and after a few replies, guys helped me solve my problem. I replaced the upstream O2 sensor and cleaned the throttle body. Not sure which one fixed the problem, but its gone. Been driving the car for two weeks and no hesitations at all. I believe.....but don't quote me, that if you give the jeep full throttle and it DOES NOT hesitate, then its the sensor....and that was the case with mine. Just cleaned the TB as a precautionary measure. Again, I am no expert, just what worked for me.

Kevin

Gorving3 03-18-2012 10:51 PM

Thanks for the response Kevin. Don't usually give it full throttle before a good warm up and by that time any hesitations are usually not there. This hesitation us generally just under slight throttle pressure during the first few blocks. Next outing I'll try letting it warm up in the driveway then give it a good run right off first thing to see if it hesitates then.

Allen

WaterDR 03-18-2012 11:57 PM

The reason why I think going to full throttle tests the O2 sensor is because the computer goes into open loop and does not use the sensor to control fuel addition.

Gorving3 03-19-2012 10:37 AM

Changing a sensor would be no problem, I know what they look like and where they are. But I'm not sure what is meant by cleaning the throttle body, where the cleaning needs to be done, or how to do it. Is there any explanation anyplace on the Forum or other web sites?

Thanks.
Allen

WaterDR 03-19-2012 07:26 PM

I doubt the TB is dirty. The idle air controller (iac) though might be a different story.

I will take a picture of it for you.


All times are GMT -5. The time now is 10:24 AM.