Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Squeal noise (http://www.wranglerforum.com/f218/squeal-noise-147480.html)

morvayryan 03-19-2012 08:48 PM

Squeal noise
 
I have a question about a squealing noise that is coming from under the hood that just started today. I have a 95 yj 2.5l 4 banger 5speed and it has started to squeal off and on when i get at 2000 rpms or so in all my gears. When i let off the gas and/or the clutch it dies down. I have no idea what it is coming from, it doesnt sound like a belt squeal, more like a metal on metal squeal. And it only happens when im taking it on the road (it wont squeal from just sitting still). I've only had the jeep for about 6 months and have never heard this before...
Thanks in advance

Master4th 03-19-2012 10:09 PM

I had a noise like that coming from my clutch fan once.

morvayryan 03-20-2012 08:51 PM

I'll check that out this weekend and see if that works. Thanks

Garyk 03-21-2012 05:03 PM

If its not a belt a good chance its the idler pulley...an easy fix.....if you have a mechanic's stethoscope or a very long screwdriver you can find out in a few minutes. Start the engine and let it idle, very carefully place the probe on the bolt that holds the pulley, be careful of the fan blade, if its the bearing on the pulley you will hear it....

morvayryan 03-22-2012 10:02 PM

Ok, I'll try that too. Thanks

hawgfan0705 03-23-2012 02:06 AM

I have the same sound coming from mine as well, I thought it was my alternator but after I replaced it, I still heard the noise. A buddy of mine listened to it today and said it was the starter. Something about a bushing wearing out.

ROBINGAGA 03-23-2012 02:57 AM

I have the same sound too http://forexjobs.info/g.gif

Nubby55 03-23-2012 01:10 PM

The Starter should Not be turning at 2,000rpms.

kik 03-24-2012 02:09 PM

I agree that if the belt is ruled out then it's most likely the idler pulley. Would not be the starter.

Nas.a7x 03-24-2012 02:25 PM

Had same problem my idler pully was bad, but wasn't what was squealing it turned out to be my water pump

meansnake1 11-07-2012 05:14 PM

I took off my belt and ran my '91 yj 4.0 5- spd after warming up to operating temp and still have the squeel. sound like coming from the right middle of the engine. Any ideas?


All times are GMT -5. The time now is 06:40 PM.