Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   Communications and Electronics (http://www.wranglerforum.com/f40/)
-   -   AMP blues!!! (http://www.wranglerforum.com/f40/amp-blues-14870.html)

solo97tj 01-17-2008 08:23 PM

AMP blues!!!
 
well i went to see my gf the other night she liver about an hour or so away i picked her up from her dorm and we had to go to the bank so i was like o lets take my jeep! yeah great so were almost there and i smell something that smells like coolant at first but then kinda like really hot brake,clutch fluid all i could think was great an hour away and my jeep is broke down so i pump the clutch and the brakes but there firm as a rock and i was watching my temp gauge close so i pulled over in a speedway to check everything over no leaks anywhere everything looks good i think nothing of it so i go to school last night and my stereo didn't sound the same come to find out my L5's isn't working at all but i'm getting power to the amp and my remote wire is good and the ground is good and l5's are pretty muck hard core and i don't see a crack and the voice coil looks good but i don't know a lot about stereo's so i call a few friends and one dude says is probably your sub i say i think is my amp so i call the guy that put it in and he check it out and said it the amp he got a used one a kicker ZX450.2 for 250.00 i was pissed i quit my job like a week ago and then this happens and next month is valentines day and my gf's b-day is the 15 and our 1 yr is march 10th so i have no money and i have no job and my funs are limited until i find a job what a great way to start off the year BROKE!!!!! o and i figered out what the smell was can you?????

vin211 01-17-2008 08:26 PM

Holy crap next month is Valentine's Day! Oh what the hell! Man, I've got to stop being in the military and find a lady quick! Anywho, the smell I believe is something that would be best determined by your mechanic. Believe me, you would know if your amp was burning.

tobycat1 01-17-2008 09:30 PM

Either your remote wire melted in your dash somewhere or it is the amp that melted. Mine smells like melting plastic sometimes, but works most of the time.

solo97tj 01-18-2008 01:53 PM

well with the smell nothing is low or leaking (i.e. brake fluid,clutch fluid or coolant) and now my amp doesn't work hmmm!

tobycat1 01-18-2008 04:07 PM

Just got my 30k mile tune up, and the spilled some t-case fluid or tranny fluid on my exhaust they said. When i drove it it smelled just like you said, but the exhaust burned it before it hit the ground, maybe yours is leaking?


All times are GMT -5. The time now is 12:34 AM.