Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Check Engine and ETC Light (http://www.wranglerforum.com/f274/check-engine-and-etc-light-148897.html)

Blackened 03-25-2012 06:00 PM

Check Engine and ETC Light
 
So my check engine light came on today and about a half mile later so did the electronic throttle control light. Only 2,000 miles on it and I barely got it home because it kept wanting to stall out at lower RPM's. Here is the list of 7 codes I pulled..

P0306 Cylinder 6 Misfire
P0201 Injector CKT open cylinder 1
P0202 Injector CKT open cylinder 2
P0203 Injector CKT open cylinder 3
P0204 Injector CKT open cylinder 4
P0205 Injector CKT open cylinder 5
P0206 Injector CKT open cylinder 6


Does anyone know if this is related to the ticking Penastar thread? I haven't been keeping up with it.

Blackened 03-26-2012 11:54 AM

Really no one has gotten these codes on a 12 yet? I feel special now.. and not in a good way.

kjeeper10 03-26-2012 11:57 AM

:eek: good luck

Blackened 03-26-2012 12:11 PM

Quote:

Originally Posted by kjeeper10 (Post 2183492)
:eek: good luck



Thanks I have a feeling my JK will need it. I will keep you all updated on what the dealer says.

Revyjku08 03-26-2012 02:58 PM

Looks like dealer time! May have some faulty spark plug wires or maybe a sensor???

Blackened 03-26-2012 05:37 PM

Got it in to the dealer today. They think it may need a new PCM but will know more info tomorrow.

kjeeper10 03-26-2012 05:50 PM

Quote:

Originally Posted by Blackened
Got it in to the dealer today. They think it may need a new PCM but will know more info tomorrow.

Member Willie I believe has his 12 back and forth to the dealer. PCM was replaced I think. Turned out to be an electrical short.
Just something to point out :)

willee51 03-26-2012 06:16 PM

Yep!
 
Quote:

Originally Posted by kjeeper10 (Post 2184766)
Member Willie I believe has his 12 back and forth to the dealer. PCM was replaced I think. Turned out to be an electrical short.
Just something to point out :)

-------------------
Engine failed 3X (once during the Dealer test-drive after fix #2)! The fix was, well, a real "bandaid-fix"! Still running for now!

I kept blowing "coil paks" :whistling:, all at hi-way speed :facepalm:

When deep in the Blue Ridge Mtns, many miles from any paved-road, I am still concerned about failure #4, due to the "bandaid-fix" :popcorn:

Blackened 03-26-2012 08:34 PM

Quote:

Originally Posted by willee51 (Post 2184885)
-------------------
Engine failed 3X (once during the Dealer test-drive after fix #2)! The fix was, well, a real "bandaid-fix"! Still running for now!

I kept blowing "coil paks" :whistling:, all at hi-way speed :facepalm:

When deep in the Blue Ridge Mtns, many miles from any paved-road, I am still concerned about failure #4, due to the "bandaid-fix" :popcorn:


Wait so did they replace your PCM?

Blackened 03-27-2012 02:05 PM

Got a call today and they are saying it is the PCM. They are trying to track one down and hopefully I will have it back by tomorrow.

willee51 03-27-2012 03:34 PM

Quote:

Originally Posted by Blackened (Post 2185492)
Wait so did they replace your PCM?

They said that they determined the PCM was not the cause :confused:

Blackened 03-27-2012 04:27 PM

Quote:

Originally Posted by willee51 (Post 2188396)
They said that they determined the PCM was not the cause :confused:


Oh ok. Well hopefully it is the cause with mine and is fixed after they replace it. Good luck with yours, I hope what they did is more than a patch.

willee51 03-28-2012 06:14 AM

Quote:

Originally Posted by Blackened (Post 2188538)
Oh ok. Well hopefully it is the cause with mine and is fixed after they replace it. Good luck with yours, I hope what they did is more than a patch.

NOPE! A "patch" is exactly what the fix is :facepalm:

They split a section of rubber-hose and used wire-ties to cover the metal end of a air-cond hose, that they said was causing the grounding problem with an electrical-line :confused:

??????????????? My opinion, it's all a cover-up, but I have all documentation and have the life-time warranty!

The next failure, #4, I am gettig a Laywer and sueing under the VA Lemon Law!

All total it was in the shop about 3-weeks :banghead:

Blackened 03-28-2012 06:23 PM

Well I got mine back today after the PCM was replaced and so far so good. Seems to be running fine, crossing my fingers that it stays that way.

tcass 04-01-2012 09:35 AM

k...help me out here....PCM...... ?-Control-Module? Gonna have to see what they say about mine.

cass

Blackened 04-01-2012 03:26 PM

Quote:

Originally Posted by tcass (Post 2206310)
k...help me out here....PCM...... ?-Control-Module? Gonna have to see what they say about mine.

cass


Powertrain Control Module. Let me know if they say the same thing is wrong with yours.


All times are GMT -5. The time now is 07:55 AM.